Вопрос appmenu на Xubuntu 12.10


Кто-нибудь, кто успешно использовал appmenu (что когда-то называлось Глобальное меню в Gnome 2.x) на Xubuntu 12.10?

enter image description here

Прежде чем ответить, обратите внимание, что я попробовал с xfapplet (который больше не доступен в 12.10) и с этим пакетом XFCE appmenu, который зависит от старого libindicator6 (на 12.10 есть libindicator7).


2
2018-01-07 14:28


происхождения


Что вы подразумеваете под «appmenu»? У вас есть Xfce's Applications Menu а также xfce4-whiskermenu, Вы ищете что-то еще? - landroni
Я был. Appmenu - это ответ «Ubuntu» на то, что когда-то называлось Глобальное меню в Gnome 2.x. Однако это уже не имеет значения, этот вопрос устарел для меня, поскольку речь идет о дистрибутиве, который скоро будет прекращен. - dadexix86
Я все еще не понимаю, что делает этот Appmenu. Не могли бы вы предоставить ссылку в исходном вопросе? - landroni
Я изменил предыдущий комментарий :) - dadexix86
Хорошо, спасибо. Я немного изменил первоначальный вопрос. Я заинтересован в том, как добиться этого в Xfce, но я не могу вспомнить, чтобы прочитать о решении. (Может быть, xfce4-индикатор?) - landroni


ответы:


Поскольку этот пакет уже доступен в PPA: заместитель warl0ck-1989 / Xfce-appmenu-плагин, вы можете действовать следующим образом:

  1. Создайте персональный PPA, используя свою учетную запись Launchpad.
  2. Идти к PPA: заместитель warl0ck-1989 / Xfce-appmenu-плагин и доступ View package details > Copy packages,
  3. Выберите желаемый пакет (скажем, тот, который Precise) и скопируйте его в свой персональный PPA. + Изменить Destination series на все, что вам нужно (здесь, 12.10 или Quantal). Гарантировать, что Rebuild the copied sources , что позволит создавать двоичные файлы с использованием доступных библиотек в выбранном дистрибутиве.
  4. Нажмите Copy Packages,

Эти инструкции являются универсальными и будут работать для любого пакета, который уже доступен на Launchpad PPA, и для любого дистрибутива, который в настоящее время поддерживается Launchpad. Они могут выйти из строя, особенно если выбранный дистрибутив не предоставляет необходимую библиотеку или конкретную версию библиотеки.

Но, похоже, это работает в этом случае. Для доказательства точки, проверьте xfce4-appmenu-plugin что я скопировал мой тестовый PPA, (Игнорируйте, что version строка содержит 0.10-0~2~precise1: пакет был построен против Quantal, так как вы можете проверить View package details в Series колонка.)


0
2018-01-13 19:14