Вопрос Как установить значение по умолчанию для ruby ​​2.1.2?


У меня рубин 1.9.3 и 2.1.2. Когда я открываю терминал по умолчанию, он использует ruby ​​1.9.3, но я хочу использовать ruby ​​2.1.2.

Как установить значение Ruby 2.1.2 в качестве значения по умолчанию?


12
2017-10-03 18:28


происхождения




ответы:


Вы должны установить РВМ для управления вашими версиями Ruby. Для установки RVM do

sudo apt-get install zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2 libxml2-dev libxslt-dev gawk libgdbm-dev libncurses5-dev automake libtool bison libffi-dev nodejs
\curl -sSL https://get.rvm.io | bash -s stable

Если это почему-то ломается, следуйте инструкциям здесь: https://stackoverflow.com/a/9056395/2376036

Затем, чтобы сделать значение по умолчанию 2.1.2

rvm --default use 2.1.2

6
2017-10-03 19:06



Привет, Большое вам спасибо за вашу любезную помощь. Да, я следил за вашими инструкциями, но в терминале при установке rvm он говорит «сломанный пакет rvm, пожалуйста, проверьте stackoverflow.com/a/9056395/497756"; поэтому я пошел по пути и добился успеха, спасибо за вашу помощь - Rasool
Рад, что я мог бы помочь, пожалуйста, отметьте мой ответ так, как принято, чтобы люди в будущем могли знать, что сработало для вас. Я добавлю дополнительный контекст из вашего комментария в свой ответ. - Termhn


/usr/bin/ruby обычно является ссылкой на /etc/alternatives/ruby, который, в свою очередь, ссылается на исполняемый файл стандартной версии Ruby (например, /usr/bin/ruby1.9). Вы можете изменить настроенную версию по умолчанию:

sudo update-alternatives --config ruby

Если желаемая версия не настроена как альтернатива для ruby (например, если он не настроен менеджером пакетов), вы можете сделать это самостоятельно с помощью

sudo update-alternatives --install /usr/bin/ruby ruby /path/to/ruby2.1 <PRIORITY>

где <PRIORITY> является положительным целым числом. Затем вы можете выполнить первый шаг.

Подробнее см. руководство по update-alternatives(8),


17
2017-10-04 01:20





На Ubuntu 14.04 вы можете установить ruby2.0 пакет. В настоящее время пакет предлагает версию 2.0.0p384 (в конечном итоге пакет может предложить Ruby 2.1 или новее). Это простой способ установки рубиновых двоичных файлов:

sudo apt install ruby2.0

Тогда у вас будут бинарные файлы ruby2.0 а также gem2.0, Для замены стандартного ruby ​​1.9 на 2.0 вы можете сделать следующее (ЗАМЕТКА: вы можете разорвать приложения, которые строго требуют Ruby <= 1.9).

sudo update-alternatives --set /usr/bin/ruby ruby /usr/bin/ruby2.0 10
sudo update-alternatives --set /usr/bin/gem gem /usr/bin/gem2.0 10

Другие возможности используют некоторый рубиновый менеджер версий, например rbenv или РВМ, Первый сложнее настроить, но менее хакерский, чем RVM. Оба позволяют установить почти любую версию Ruby, которую вы хотели бы использовать.


6
2018-01-14 16:52



Вы уверены, что установочный переключатель правильно. stackoverflow.com/a/1892889/525174 ответ мне помог, но только разница в использовании --set switch. - Denis Besic


Если вы используете Ubuntu 14.04 (Trusty) или новее, вы можете добавить этот PPA:

sudo apt-get install software-properties-common
sudo apt-add-repository ppa:brightbox/ruby-ng
sudo apt-get update

Затем вы можете установить какой бы пакет вы ни хотели, например

sudo apt-get install ruby2.2

Чтобы иметь возможность создавать собственные расширения, вам также понадобится dev-пакет

sudo apt-get install ruby2.2-dev

Чтобы легко переключаться между установленными версиями Ruby, установите рубиновый переключатель:

sudo apt-get install ruby-switch

Команды утилиты

ruby -v
ruby-switch --list

пример

sudo ruby-switch --set ruby2.1

Из: https://www.brightbox.com/docs/ruby/ubuntu/


3
2018-03-17 20:14