Вопрос Не удалось установить OpenJDK 9 на 32-разрядные Lubuntu или 64-разрядные машины Ubuntu


Я расчесываюсь на Java, работая из книги Deitel Java 9 для программистов. Первые 15 глав требовали Java SE 8, и я помню, что процесс установки был простой задачей командной строки - sudo apt-get install ... и т.п.

В конце главы 16 приведен первый пример, требующий Java 9, который остановил мой прогресс. Сегодня я провел около 2 часов, пытаясь найти способ установить OpenJDK 9. Ошибка:

E: Unable to locate package openjdk-9-jdk

Кажется, самая большая трудность заключается в поиске каких-либо результатов для этой точной ошибки. Есть множество сообщений о различных проблемах с установкой OpenJDK 9, хотя большинство результатов поиска для OpenJDK 8. Несколько сообщений советуют использовать команду, которую я использовал - sudo apt-get install openjdk-9-jdk, Я убедился, что вселенские хранилища мультивселенной включены, sudo apt-get update и т. д., но никакой радости.

Можно ли установить JDK 9 на Ubuntu?


1
2018-05-30 21:21


происхождения


JDK 9 больше не поддерживается. Вместо этого используйте JDK10. Он должен быть обратно совместим. en.wikipedia.org/wiki/Java_version_history - Ward Segers
Ах, я вижу, спасибо! - PaulS


ответы:


JDK 9 больше не поддерживается. Вы должны использовать JDK 10 (или любую новую версию). Подробнее на странице Википедии История версий Java,

Для этого установите по умолчанию-JDK пакет.


3
2018-05-30 21:36