Вопрос Проблема с перезапуском Apache 2 [дубликат]


На этот вопрос уже есть ответ:

Я пытаюсь перезапустить Apache 2:

sudo service apache2 restart

Но получите следующую ошибку:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

Я попытался изменить

sudo gedit /etc/apache2/httpd.conf

Появится пустой файл, и я добавил следующее:

ServerName localhost

Но эта ошибка не исчезает!

Как я могу исправить эту проблему?


74
2017-08-06 13:42


происхождения


хорошо вы проверили ссылку, которую я разместил? Ошибка явно то же самое. попробуйте «мой» ответ ниже. - Meintjes


ответы:


Я нашел это: Как перезапустить / перезагрузить Apache, если он не может определить имя домена?

Хорошие новости! Apache успешно перезапускается. Apache просто не уверен   где вы хотите обслуживать, поэтому он выбирает ваш localhost (127.0.0.1)   по умолчанию. Чтобы предотвратить появление этого сообщения, уточните, что вы   хотите работать с localhost (127.0.0.1), добавив следующую строку   в ваш /etc/apache2/apache2.conf файл:

ServerName localhost

111
2017-08-06 13:52



При желании вы можете добавить это в раздел «Глобальная конфигурация». Заказ не имеет значения, но если вы пытаетесь найти его позже, это помогает организации. - Dez
В более новых версиях Ubuntu может быть более целесообразным поместить его в /etc/apache2/conf-available/ServerName.conf, а затем запустить 'sudo a2enconf ServerName'. Таким образом, вы не изменяете конфигурацию, управляемую приложениями, и вы ее переопределите, если по какой-то причине она изменится в будущей версии. - flickerfly
Спасибо, спасибо. Я проголосовал за этот ответ. - Yufenyuy Veyeh Dider


Определение ServerName localhost в ваших конфигурационных файлах за пределами виртуальных разделов хоста это способ сделать это.

Другие ответы предполагают, что вы должны изменить /etc/apache2/httpd.conf, Этот файл перезаписывается, когда apache обновляется с apt. Для конфигурации Apache, которую вы не хотите перезаписывать, вы должны создать новый файл. Ниже приведен пример «Debian» для изменения этой конфигурации:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart

34
2018-03-10 20:03



более чистое решение возможно - khaled_webdev
Это должен быть принятый ответ. В настоящее время принятый будет заменен на обновление. - Scottie


Ваш IP-адрес localhost должен быть 127.0.0.1, а не 127.0.1.1. Пожалуйста, настройте /etc/hosts файл. Затем отредактируйте httpd.conf файл:

sudo -H gedit /etc/apache2/httpd.conf

Когда появится пустой файл, добавьте эту строку, а затем сохраните:

ServerName localhost

4
2018-03-02 12:36





Вот еще одно решение:

До:

[root@centos ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

добавленной 192.168.226.131 centos.wks.local в /etc/hosts файл

Примечание. 192.168.226.131 - это мой IP-адрес сервера Apache.

После:

[root@centos ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]

0
2017-08-06 14:02



нет /etc/init.d/httpd для Apache на Ubuntu. Это /etc/init.d/apache2, Просто указывая. - moon.musick
Да, это от CentOS, но решение будет работать, потому что требуется полное доменное имя - Rahul Patil
редактирование /etc/hosts это, по меньшей мере, плохая практика. - JakeGould