Вопрос Я не могу установить что-либо с apt-get и не могу добавить репозитории либо [duplicate]


На этот вопрос уже есть ответ:

Я использую программу под названием SimpleScreenRecorder для записи видео для YouTube. У меня возникла проблема с этим при попытке запустить его, поэтому я решил переустановить его. Когда я пытаюсь запустить команду sudo add-apt-repository ppa:maarten-baert/simplescreenrecorder это говорит мне об этом:

Traceback (most recent call last):
  File "/usr/bin/add-apt-repository", line 91, in <module>
    sp = SoftwareProperties(options=options)
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 109, in __init__
    self.reload_sourceslist()
  File "/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py", line 599, in reload_sourceslist
    self.distro.get_sources(self.sourceslist)    
  File "/usr/lib/python3/dist-packages/aptsources/distro.py", line 89, in get_sources
    (self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Ubuntu/xenial

Этого не происходит, когда я запускаю sudo apt-get update и он говорит это (на всякий случай что-то не так)

Hit:1 http://archive.ubuntu.com/ubuntu xenial InRelease
Get:2 http://archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:3 http://archive.ubuntu.com/ubuntu xenial-security InRelease [102 kB]
Fetched 204 kB in 1s (178 kB/s)                             
Reading package lists... Done

Когда я пытаюсь запустить sudo apt-get install simplescreenrecorder он дает мне этот результат:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package simplescreenrecorder

и SimpleScreenRecorder не устанавливается. То же самое происходит, когда я пытаюсь установить LiVES даже на одни и те же результаты, и у меня были те же проблемы.

Я запускаю Ubuntu 16.04.2


1
2018-03-08 23:30


происхождения


Хорошо, поэтому я просто добился установки LiVES, но у меня была такая же проблема с репозиторией, поэтому мне пришлось запускать другую команду. - Likebeingawesome


ответы:


Скорее всего, у вас нет правильного репозитория, указанного в файле /etc/apt/sources.list. У поддерживающей установки есть страница справки по установке, расположенная здесь http://www.maartenbaert.be/simplescreenrecorder/

В котором вам предлагается добавить PPA, используя следующие команды:

sudo add-apt-repository ppa:maarten-baert/simplescreenrecorder
sudo apt-get update
sudo apt-get install simplescreenrecorder
# if you want to record 32-bit OpenGL applications on a 64-bit system:
sudo apt-get install simplescreenrecorder-lib:i386

Кроме того, убедитесь, что у вас есть общие свойства программного обеспечения, или вы не сможете добавить PPA, и если вы получите сообщение об ошибке, попробуйте установить его с помощью этого:

sudo apt-get install software-properties-common

3
2018-03-08 23:42



Вам не нужно упоминать, как установить SimpleScreenRecorder. ОП уже знает. Вы можете отбросить свой ответ только до части software-properties-common, - wjandrea
Он по-прежнему дал мне то же сообщение об ошибке, что и я упоминал выше, в случае, если это поможет мне использовать эту команду для установки обновления sudo apt для жизни && sudo apt install lives ' - Likebeingawesome
@Likebeingawesome и вы получили успешный выход при добавлении PPA? - The Cleric
Как установить программные свойства - общие и я не получил успешный вывод - Likebeingawesome
Итак, у меня уже есть общие свойства программного обеспечения, но я все еще не могу добавить репозитории PPA - Likebeingawesome