Вопрос Фоновое изображение не отображается на экране входа в систему. 14,04


Поэтому я изменил свой фон на своем компьютере на изображение, которое мне понравилось в Интернете. Однако, в отличие от моего ноутбука, фоновое изображение не отображается для входа в мою учетную запись пользователя. Есть ли способ исправить это на 14.04?


1
2017-10-09 19:40


происхождения


вы включили шифрование домашней папки? если это так, что фоновое изображение недоступно, пока вы не войдете в систему. - Minos
@ Минос Нет, я этого не делал. Я не думал, что это необходимо, потому что на моем ноутбуке компьютер сделал это автоматически. Это что-то, что я могу сделать из системных настроек или мне нужно возиться с терминалом? - Msd1391


ответы:


Установите dconf-editor либо через программный центр Ubuntu, либо через CLI.

В dconf-editor перейдите по ссылке: com> canonical> unity> unity-greeter

а затем убедитесь, что для флажка для галочки нажмите -Инфо-фоны установлено значение Истина.

image of dconf-editor and unity-greeter settings


1
2017-10-10 06:54



Я попробовал, и у него уже была коробка. - Msd1391


Другой причиной этого могут быть неправильные разрешения для файла изображения и / или папки, в которой он находится. Это случилось со мной.

Разрешения для папок должны быть 775(rwxrwxr-x) и для файлов изображений 664(RW-RW-r--).

Например, если у вас есть:

./wallpapers/animals/cat_0.jpg

wallpapers а также animals должны иметь разрешения 775 а также cat_0.jpg - 664, Вы можете установить разрешения с помощью chmod:

chmod 775 [folder/file name]

1
2017-07-18 07:35





Выполните следующие действия, чтобы настроить фоновое изображение:

  1. Если ваши обои находятся в другом разделе, скопируйте его в свою домашнюю папку - например, в папку с картинками.
  2. Щелкните правой кнопкой мыши по нему и выберите Properties затем выберите permissions Вкладка. Установите разрешения как:

владелец - Чтение и запись
  Группа - чтение и запись
  Другие - Только для чтения

  1. Откройте обои в Image Viewer (EOG), затем щелкните правой кнопкой мыши и выберите Set as Wallpaper

(На этом этапе вы можете попробовать выйти и проверить, появилось ли изображение в качестве фонового изображения входа). Если нет, продолжайте - хотя не будет никакого вреда в продолжении все-таки.

  1. Установка Ubuntu Tweak
  2. Откройте Ubuntu Tweak и выберите Tweaks затем нажмите Login Settings раздел - см. снимок экрана ниже:

enter image description here

  1. Разблокируйте настройки с помощью пароля - см. Снимок экрана ниже:

enter image description here

  1. Прокрутите вниз и нажмите Set the same background as the current desktop background кнопка - см. снимок экрана ниже:

enter image description here

  1. И все, обои были установлены как фон входа.

Вот моя настройка:

Рабочий стол:

enter image description here

Экран входа в систему:
https://askubuntu.com/a/607095/163331

enter image description here


1
2018-04-09 07:46





если все остальное не удалось преобразовать графику в другой формат .. в прошлом были графики, которые будут отображаться в качестве обоев при входе в систему, но не будут работать для экрана входа в систему до тех пор, пока формат не будет изменен .. забудьте, что действительный формат был уверен, что вы можете понять, что один с небольшим экспериментом.

ох .. и забыл об этом .. но если вы используете отдельную среду рабочего стола вместо единицы, то вы должны изменить фоновый рисунок в единстве, потому что единственному приветствию не важно, какой фон вы используете в других средах рабочего стола. для меня есть lxde, поэтому всегда нужно помнить о том, чтобы менять обои в единстве так же, как мой фон в lxde.


0
2018-04-09 05:55





Вы можете установить его var/lib/AccountsService/users/yourusername, под [User] раздел. Я использую этот самый файл, чтобы установить фон входа в систему, отличный от рабочего стола.

Вот как выглядит мой. Обратите внимание на Background= линия

[com.canonical.indicator.sound.AccountsService]
PlayerName=''
Timestamp=0
Title=''
Artist=''
Album=''
ArtUrl=''
PlayerIcon=<('themed', <['application-default-icon', 'application-default', 'application']>)>

[User]
Language=en
FormatsLocale=en_US.UTF-8
XSession=gnome
Background=/usr/share/backgrounds/LOGIN-WARNING.png
Icon=/usr/share/pixmaps/faces/penguin.jpg
SystemAccount=false

[InputSource0]
ibus=pinyin

[InputSource1]
xkb=us

[InputSource2]
xkb=ru

0
2018-04-09 06:25