Вопрос Как установить screem?


Я загрузил Screem (среда веб-разработки) и попыталась скомпилировать его, но после запуска ./configure  Я получаю эту ошибку.

checking for SCREEM... configure: error: Package requirements (         gtk+-2.0 >= 2.6.0                       glib-2.0 >= 2.6.0                       libgnome-2.0 >= 2.2.0                       libgnomeui-2.0 >= 2.6.0     libxml-2.0 >= 2.4.3                     libglade-2.0 >= 2.3.0                       gconf-2.0 >= 2.2.0gnome-vfs-2.0 >= 2.8.3                        gdk-pixbuf-2.0 >= 2.2.0                     gthread-2.0 >= 2.2.0                        libgtkhtml-2.0 >= 2.2.0                     gmodule-2.0 >= 2.2.0            libgnomeprint-2.2 >= 2.2.0                  libgnomeprintui-2.2 >= 2.2.0                    gtksourceview-1.0 >= 1.1.90                     libstartup-notification-1.0                                     libgnome-menu >= 2.9.2      ) were not met:

No package 'libgtkhtml-2.0' found
No package 'libgnomeprint-2.2' found
No package 'libgnomeprintui-2.2' found
No package 'gtksourceview-1.0' found
No package 'libgnome-menu' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables SCREEM_CFLAGS
and SCREEM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Я попытался найти недостающие пакеты, используя apt-cache search но не удача, за исключением libgnome-menu

Как установить screem в Ubuntu 12.10 (amd64)


1
2017-12-07 17:38


происхождения




ответы:


Screem был в хранилищах для Hardy (8.04 LTS), так как это На странице Launchpad отображается, но это было около пяти лет назад. Пакеты Ubuntu страница содержит подробную информацию об этом, но проблема при установке или компиляции заключается в том, что для нее требуются очень старые зависимости, которые несовместимы с текущими пакетами 12.10.

Пакет, который вы упомянули, «libgtkhtml-2.0» был в репозиториях для Харди с сопровождающим -dev файлы, необходимые для компиляции, как и большинство других необходимых зависимостей, но они не могут быть установлены в систему 12.10, не вызывая много проблем.

К сожалению, долгое время не было активного развития проекта, списки рассылки и кодекс совершает, хотя кто-то попробовал компиляцию в последнее время (2011 г.) и ответ отмеченные в списках рассылки, могут дать вам некоторую помощь, поскольку это указывает на более новую версию проекта. Тем не менее, я думаю, что та же проблема с зависимостями будет присутствовать.


3
2017-12-07 18:47



Правда! 'libgtkhtml-2.0' 'gdl-1.0' и 'libgnome-menu' не найдены. к плохому, я также не мог найти зависимости в packages.ubuntu.com :( Я приму свой ответ! - blade19899