Вопрос Установка gedit 3.11.2


Я пытаюсь установить gedit 3.11.2 из:

https://git.gnome.org/browse/gedit

по какой-то причине он не работает на моем ubuntu 13.10

файл ./configure не найден.

я выполнил шаги в README файл:

  % tar Jxf gedit-3.11.2.tar.xz         # unpack the sources
  % cd gedit-3.11.2             # change to the toplevel directory
  % ./configure                 # run the `configure' script
  % make                    # build gedit
  [ Become root if necessary ]
  % make install                # install gedit

но тогда configure не найден. Я что-то упустил?


1
2018-01-17 19:37


происхождения


yep, нет файла конфигурации. Вам необходимо отправить отчет об ошибках сопровождающим. Вы мог бы иметь возможность запускать autogen.sh. Попробуйте запустить chomd a+x autogen.sh && autogen.sh, затем продолжайте ./configure ... - Panther


ответы:


Вы должны получить пакет от:

http://ftp.gnome.org/pub/GNOME/sources/gedit/3.11/

Возможно, вам не хватает какой-либо библиотеки. Вы можете получить их, установив их:

sudo add-apt-repository ppa:ricotz/testing
sudo apt-get update

sudo apt-get install intltool
sudo apt-get install itstool
sudo apt-get install libxml2 libglib2.0-dev libxml2-dev libxml2-utils
sudo apt-get install libxml2-dev
sudo apt-get install libgtksourceviewmm-3.0-dev
sudo apt-get install libpeas-1.0-0 libpeas-dev
sudo apt-get install gsettings-desktop-schemas-dev   
sudo apt-get install libgtkspell3-3-dev libgtkspell3-3-0 libgtksourceview-3.0-dev
sudo apt-get install gtk+3.0
sudo apt-get install gir1.2-gtk-3.0

У меня возникла проблема с получением gtksourceview, Мне пришлось установить его вручную:

http://ftp.acc.umu.se/pub/GNOME/sources/gtksourceview/3.11/

такая же сделка:

./configure
make 
sudo make install

УСТАНОВКА Gedit

Затем, как только все будет завершено, вы можете запустить в папке gedit:

./configure
make
sudo make install

ПРИМЕЧАНИЕ. В новой библиотеке GTK могут возникнуть некоторые проблемы с графикой. Проверьте драйверы (например, nvidia или ati) или играйте с настройками «внешний вид».


2
2018-01-17 23:26



Мне всегда нравилось «apt-get build-dep» для установки зависимостей, поэтому в данном случае «apt-get build-dep gedit». Он получит все необходимые вам зависимости. Конечно, он знает только о зависимостях для версии в репозитории ubuntu, но я считаю, что он обычно получает правильный набор. - Joe