Вопрос Проблемы с обновлением Ubuntu с 12.10 по 13.04


Я пытаюсь обновить версию Ubuntu с 12.10 по 13.04, успешно обновив ее до 12.10. С намерением затем перейти к 13.10.

Я ознакомлен с другими обновлениями программного обеспечения.

Используя диспетчер обновлений, мне предлагается обновить версию, но она предлагает обновление до 13.10 вместо ожидаемого 13.04.

При выборе обновления это на самом деле пытается обновить до 13.10 «Saucy», приложение говорит мне о том, чтобы сделать это правильно, и отправляет меня.

Любые идеи, как я могу обновить до 13.04?


1
2017-12-17 23:15


происхождения


Если вам предлагают 13,10, вы должны быть в 13.04. Вы также не можете напрямую обновлять с 10.10 до всего, кроме 11.04, оба из которых были в конце срока службы и не поддерживались в течение некоторого времени, предотвращая обновление, если вы не уходите с пути, чтобы включить устаревший репозиторий. - psusi
Привет, psusi, спасибо за ваш ответ. извините, что ранее неправильно, я на самом деле на 12.10, проверив на терминале следующую информацию о выпуске: ID дистрибьютора: Ubuntu Описание: Ubuntu 12.10 Release: 12.10 Codename: quantal - Lee


ответы:


Вы должны использовать update-manager-core из quantal-updates вместо quantal-proposed,

Видеть: Я не знаю, как обновить 12.10 до 13.04 или 13.10


1
2017-12-20 15:48



Андреас - спасибо за ваш ответ, обработал удовольствие. обновлено до 13.04, как предлагается с использованием ядра update-manager. Затем 13.10 через update-manager. Большое спасибо. - Lee


Определенная ситуация вокруг этого заключается в том, что пакет обновления-менеджера не поддерживает обновления до дерзких ... ну, на сегодняшний день.

Может быть, так оно и было в прошлом, и, возможно, в будущем это может повториться. Но по состоянию на апрель 2014 года этот инструмент не поддерживает апгрейды до дерзкого. Возможно, это может быть связано с EOL'ing of Raring (13.04) .. и, возможно, также необходимость прямого обновления с 12.10 по 13.10.

Единственное, что сработало для меня, было:

  • s / quantal / saucy / in /etc/apt/sources.list
  • Обновление apt-get
  • apt-get dist-upgrade

1
2018-04-15 11:57





Это будет то, что вы должны делать:

sudo apt-get -y dist-upgrade

это приведет к обновлению всех ваших файлов зависимостей, проще всего до перехода на Saucy. Эта следующая команда позволит вам перейти на Saucy:

sudo do-release-upgrade

то это сгорит. Удачи!


0
2017-12-17 23:25



Привет, Фарон, приветствует ответ. Я попытался это сделать, но после сообщения об ошибке «sudo do-release-upgrade» (ps я неправильно сообщил о том, какая версия i была ранее ранее) возвращается следующее сообщение об ошибке: нельзя обновить Обновление с «quantal» до «saucy» не поддерживается этим инструмент. - Lee


Это ожидается, но не так рано. С января 2014 года Raring будет EOL (End Of Life), но Quantal (который вы используете) будет поддерживаться до апреля 2014 года. Итак, что сделала команда релизов:

Таким образом, поддерживаемый путь обновления будет 12.10-> 13.10-> 14.04, начиная с января.

Вы можете почувствовать это. Они, вероятно, (я еще не нашел источники) активировали это со стороны сервера перед рукой. Я не знаю, можно ли настроить такое поведение (с клиентской стороны), и я бы не экспериментировал с ним. Вы можете попробовать обновление, если оно работает, отлично! Если это не так, сообщите об ошибке. Перед обновлением обязательно сделайте резервные копии всех ваших материалов!

Связанный:


0
2017-12-18 21:58



Привет, Braiam, попытался обновить и вернуть ошибку: lee @ lee-Aspire-5720: ~ $ sudo do-release-upgrade Проверка новой версии Ubuntu Get: 1 Подпись инструмента обновления [198 B] Получить: 2 Инструмент обновления [1,135 kB ] Получено 1,135 kB в 0 с (0 B / s) аутентифицировать 'saucy.tar.gz' против 'saucy.tar.gz.gpg' extracting 'saucy.tar.gz' Чтение кеша Проверка менеджера пакетов Невозможно обновить Обновление с 'quantal 'to' saucy 'не поддерживается этим инструментом. - Lee
«Обновление от« quantal »до« saucy » не поддерживается этим инструментом«Я думаю, что это может быть проблемой. Вместо этого попробуйте с менеджером обновлений. - Braiam
диспетчер обновлений показывает ту же ошибку при попытке .upgrade. он показывает, что я на 12.10 советует новую версию 13.10, но затем возвращает эту ошибку. Я не спешу, чтобы получить это отсортировано, так что будет держаться до janary, когда 13.04 официально EOL и не работает. Это чистая установка до 13.10 - Lee
@Braiam Пожалуйста, см. Мой ответ здесь: askubuntu.com/questions/390587/... для одного решения проблемы «не поддерживается этим инструментом». - intgr


У меня была та же проблема, и мне удалось обновить с 12.10 по 13.04 вместо 13.10:

1) Файл с открытыми версиями: sudo gedit /etc/update-manager/release-upgrades
2) Вы должны иметь Prompt=normal, этот режим обновляется до выпуска, что сразу же удаляет текущую версию.
3) Запустите обновление, используя sudo do-release-upgrade

Таким образом, у меня теперь 13.04, а не 13.10.


0
2018-01-29 12:27