Вопрос Какая минимальная установка для запуска .NET-приложения, созданного на C #, посредством monodevelop?


Я немного noobish, когда дело доходит до .NET, но мне интересно, какой минимальный пакет пакетов необходимо установить для запуска приложения .NET. Это простое консольное приложение ввода и с командой:

app_name.exe

он запускается на моем компьютере, но когда я пытаюсь запустить его на другом компьютере (который не имеет монодеволюции и всего этого), он возвращает ошибку:

не может выполнить двоичный файл

поэтому мне интересно, каковы минимальные размеры пакетов размера, которые необходимо установить?


1
2017-12-15 12:10


происхождения




ответы:


Вы должны были установить mono-runtime для запуска приложений .NET / Mono, а также Wine, если они используют особенности Windows.


2
2017-12-15 15:34



Я заметил, что если я устанавливаю monodevelop, я могу запустить приложение, но если есть только однократная версия, эта ошибка появляется снова, мое приложение использует только некоторые базовые методы System.IO и ничего больше. Есть ли какая-нибудь библиотека или что-то в этом роде, которое мне нужно установить? - antifriz
Вы можете попробовать установить libmono-microsoft-csharp-4.0-cil, - Erkin Alp Güney