Вопрос обновление от четкого до точного


Я работаю прозрачно и хочу обновиться до точности. Я изменил настройки в диспетчере обновлений на «Только для долгосрочных версий поддержки», но я получил только опцию «Новая версия Ubuntu» 10 .10 »доступна». Я подумал, что можно перейти непосредственно с одного LTS на другой (т. Е. Перейти прямо от ясного к точному). Это правильно, или мне придется пройти через все промежуточные версии?

Чтобы добавить дополнительные данные, запуск «lsb_release -a» дает: Нет доступных модулей LSB. Идентификатор дистрибьютора: Ubuntu Описание: Ubuntu 10.04.4 LTS Выпуск: 10.04 Codename: lucid

В / etc / update-manager / release-обновлениях у меня есть Prompt = lts

Выполнение do-release-upgrade дает результат: Проверка новой версии ubuntu Неверная подпись инструмента обновления Инструмент «Сбой обновления» Готово загрузить
Не удалось получить Не удалось выполнить обновление. Может возникнуть проблема с сетью.

Карлос.


1
2017-11-22 14:13


происхождения


Обновление с старой неподдерживаемой версии Ubuntu до текущей версии объясняется по адресу: https://help.ubuntu.com/community/EOLUpgrades м - milegrin


ответы:


В оболочке это просто apt-get команда. Сначала обновите списки и обновите все пакеты:

sudo apt-get update
sudo apt-get upgrade

А затем обновите дистрибутив:

sudo apt-get dist-upgrade

(Может потребоваться некоторое время!)

Если это не сработает, вам нужно использовать менеджер обновлений:

sudo aptitude install update-manager-core
sudo do-release-upgrade

Вы можете подтвердить, что находитесь на Lucid:

lsb_release -a

Должен сообщить четыре строки с 10.04 а также lucid там. Следующим шагом вам нужен менеджер обновлений, чтобы перейти к следующей LTS, а не 10.10, о которой вы упомянули выше ... vi /etc/update-manager/release-upgrades

Prompt=lts

Попробуйте и запустите do-release-upgrade again, если вы можете вставить фактическое сообщение об ошибке (в вашем Q), это тоже будет полезно.


1
2017-11-22 15:17



Я пробовал это и получаю результат: Чтение списков пакетов ... Готово Создание дерева зависимостей Чтение информации о состоянии ... Готово Расчет обновления ... Выполнено 0 обновлено, 0 вновь установлено, 0 удалено и 0 не обновлено. - Carlos Perez
Спасибо за ваши усилия @ Rudu. Использование диспетчера обновлений, по крайней мере, дает другое сообщение об ошибке, теперь он говорит: Не удалось обновить подпись инструмента Failed Upgrade tool Done downloading Failed to fetch Извлечение обновления не удалось. Может возникнуть проблема с сетью. Я знаю, что нет проблем с сетью, так ли это не подсказывает, что такое настоящая проблема? - Carlos Perez
Нет, это сходит с ума. Все выглядит идеально, но обновитель графического интерфейса предлагает мне обновление до 10.10, в то время как до-релиз-обновление дает «Ошибка подписи инструмента обновления, исправленный инструмент обновления». - Carlos Perez
@CarlosPerez, вы подтвердили, что находитесь на lsb_release? Единственная причина, по которой я могу думать, что это неудача, ты не на 10.04, но фактически на 10.10, который не поддерживает обновление до 12.04 - Rudu
Да, «lsb_release -a» сообщает «Ubuntu 10.04.4 LTS», «Release: 10.04», «Codename: lucid». Поэтому, если это не врет мне, я определенно, кажется, работает ясным! - Carlos Perez


Привет, я натолкнулся на эту тему, пытаясь сделать обновление с Lucid до Precise, и я получил ту же ошибку:

Checking for a new Ubuntu release
Failed Upgrade tool signature
Failed Upgrade tool
Done downloading
Failed to fetch Fetching the upgrade failed.
There may be a network problem.

Я нашел проблему в своем /etc/apt/apt.conf файл Мне пришлось прокомментировать это заявление:

Acquire::http::Proxy "http://old-releases.ubuntu.com/releases/dapper";

После того как я прокомментировал, работает do_release_update для меня.


1
2018-05-27 16:22