Вопрос Возможно ли, чтобы gcc 4.7 и gcc 4.8 сосуществовали в Ubuntu 13.10


У меня есть некоторые разработки, похоже, что GCC 4.8 не будет хорошо работать с другими инструментами разработки, поэтому мне, возможно, придется придерживаться GCC 4.7, но я не уверен, разрешено ли это в Ubuntu 13.10 (64 бит). Если да, может ли кто-нибудь сказать мне, как установить и настроить gcc 4.7 здесь?


1
2017-11-24 23:32


происхождения




ответы:


Да, обе версии будут радостно сосуществовать. Вы можете вызывать каждый отдельно, специально вызывая его, хотя только одна версия будет иметь CC сглаженный ему.

Устанавливайте каждый отдельно:

sudo apt-get install gcc-4.7

sudo apt-get install gcc-4.8

Когда вы готовы к компиляции с определенной версией, вызовите его явно:

gcc-4.7 source.c -o executable

или

gcc-4.8 source.c -o executable

2
2017-12-14 21:24