Вопрос Проводное соединение не работает Ubuntu 12.04


Моя связь была прекрасна до сих пор, но мое проводное соединение не работает в Ubuntu 12.04. Я установил Ubuntu 12.04 вместе с разделом Windows 7, и соединение работает в Windows, но не на Ubuntu 12.04. У меня нет проблем с беспроводным подключением. Проблема связана с проводным подключением на Ubuntu 12.04. Я привел несколько подробностей ниже.

ifconfig

eth0      Link encap:Ethernet  HWaddr 00:1e:ec:8d:f0:03  
          inet6 addr: fe80::21e:ecff:fe8d:f003/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:376 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:316 (316.0 B)  TX bytes:33769 (33.7 KB)
          Interrupt:19 

eth2      Link encap:Ethernet  HWaddr 00:21:00:4e:ac:58  
          inet6 addr: fe80::221:ff:fe4e:ac58/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:1660 errors:0 dropped:0 overruns:0 frame:28
          TX packets:1846 errors:61 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1372676 (1.3 MB)  TX bytes:254576 (254.5 KB)
          Interrupt:18 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1862 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1862 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:155767 (155.7 KB)  TX bytes:155767 (155.7 KB)

sudo lshw -C network 

 *-network               
       description: Wireless interface
       product: BCM4312 802.11b/g LP-PHY
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth2
       version: 01
       serial: 00:21:00:4e:ac:58
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=5.100.82.38 ip=10.0.0.3 latency=0 multicast=yes wireless=IEEE 802.11bg
       resources: irq:18 memory:99700000-99703fff


 *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 02
       serial: 00:1e:ec:8d:f0:03
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:19 ioport:3000(size=256) memory:93410000-93410fff memory:93400000-9340ffff memory:93420000-9343ffff

10
2017-07-09 10:08


происхождения


Перейдите в верхнюю панель Unity, выберите соединения, выберите edit conntn >> В проводной вкладке отредактируйте Auto Ethernet, затем проверьте, не отмечено ли это отметкой «Tick Marked», если не отметьте ее, и удалите отметку Tick от Wirless Conntn. Проверьте проводное соединение с Live Ubuntu Cd или USB-накопителем. - atenz


ответы:


Я столкнулся с такой же проблемой после обновления до 12.04.

Для меня работало следующее решение:

  1. Откройте этот файл в текстовом редакторе с правами root:

    gksu gedit /etc/network/interfaces
    
  2. Добавьте эти строки в файл:

    auto eth0
    iface eth0 inet dhcp
    
  3. Сохраните файл и закройте текстовый редактор.

  4. Теперь перезапустите сеть:


7
2017-10-28 02:59



также - испытывал периодический отказ DNS через моего провайдера (Comcast). Поэтому я переключился на Google DNS, что улучшило скорость моего подключения и уменьшило ошибки загрузки страницы в almonst 0. - Charles Morgan
Мой / etc / network / interfaces имеет следующее содержание: auto lo iface lo inet loopback auto eth0 iface eth0 inet dhcp и редактирование соединений -> проводное соединение -> ipv4settings -> Method -> Automatic сделал трюк. - Lavixu


Все, что мне нужно было сделать, это отключить кабель Ethernet от порта и снова подключить его. Это сработало. Смешной.


2
2017-10-20 01:24





Попробуйте включить / отключить подключения, а также удалить текущий актив и добавить его в другое время!


1
2017-07-20 12:23





Попробуй это...

Нажмите Ctrl+Alt+T и тип echo on | sudo tee /sys/class/net/eth0/device/power/control

После этого выйдите из системы, вытащите кабель Ethernet и снова подключите его после входа в систему.


0
2017-10-07 08:37





Пытаться

sudo service network-manager restart

для сброса IP-адреса тогда

sudo /etc/init.d/networking restart

После этого Check

ifconfig

посмотрите, что изменится.


0
2017-10-07 00:59