Вопрос Как отключить мнемонику в GTK3?


В Natty Narwhal я делал некоторые изящные трюки с .gtkrc-2.0 для отключения мнемоники (подчеркнутые меню), но теперь это невозможно. Я предполагаю, что в Oneiric Ocelot это будет что-то другое, потому что оно использует GTK3.

Я использовал это, добавив следующие строки:

gtk-enable-accels = 0
gtk-enable-mnemonics = 0

Как я могу избавиться от мнемоники в Oneiric Ocelot?


9
2017-11-06 16:12


происхождения


В Natty Narwhal я использовал эту информацию: ubuntuforums.org/showthread.php?p=7483418 В Oneiric Ocelot это не работает. - Chris
Этот вопрос кажется заброшенным, если вы испытываете подобную проблему, пожалуйста, задать новый вопрос с деталями, относящимися к вашей проблеме. Если вы чувствуете, что этот вопрос не заброшенный, пожалуйста, отметьте вопрос, объясняющий это. :) - jrg♦
@jrg Я оспариваю этот. Это убедительный вопрос, на который были получены все просьбы о предоставлении дополнительной информации. - Jjed
@JacobJohanEdwards пользователь не был замечен с середины ноября. Я бы определил это как заброшенное, его почти два месяца, и у него нет ответа. - jrg♦
@jrg Статус исходного пользователя не имеет значения. Это реальный вопрос, который не подходит ни к одной из категорий закрытого голосования, и может быть одобрен сообществом сообщества. - Jjed


ответы:


GTK3 больше не использует gtkrc, но перешел к стилизации с помощью CSS. Но все же есть способ изменить глобальные настройки. Цитирование из Ссылка GTK:

GTK + считывает значения по умолчанию для параметров из файлов settings.ini в /etc/gtk-3.0 и $ XDG_CONFIG_HOME / gtk-3.0.

См. Эту страницу для получения более подробной информации.

Интересно, работает ли это в Unity, с глобальным меню. Я не знаю, адаптированы ли эти настройки.


2
2018-02-05 23:35





После такого долгого времени и ответа на мой вопрос я не нашел его!

Чтобы скрыть мнемонику (ускорители клавиатуры) в GTK 3.x, вам просто нужно открыть:

/usr/share/themes/THEME_NAME/gtk-3.0/settings.ini

Добавьте следующую строку:

gtk-enable-mnemonics = 0

И сохраните файл. Выйдите из системы или измените тему с другой, затем измените ее. Это все. Ничего сложного, мало исследований.

PS: Конечно, после обновления пакета ubuntu-light-themes это будет потеряно и нужно будет снова переделать.


2
2018-05-18 14:26





«Отключить» мнемонику для Nautilus 3.10.1 на Ubuntu 14.04, который использует GTK3:

  1. Создайте следующий путь и файл, если он еще не существует.
    /home/YOURUSERNAME/.config/gtk-3.0/settings.ini
  2. Затем добавьте:
    [Settings]
    gtk-enable-mnemonics = 0
  3. Затем выйдите из системы и войдите в систему.

Источники:
* https://mail.gnome.org/archives/gtk-list/2011-March/msg00108.html
* https://developer.gnome.org/gtk3/stable/GtkSettings.html

постскриптум Обратите внимание, что в документах GTK говорится, что у вас должна быть переменная среды, называемая XDG_CONFIG_HOME но у меня его не было. У меня было существующее ~/.config/gtk-3.0 и кажется, что он ищет по умолчанию, без переменной окружения.


1
2018-01-05 21:07





Добавить

gtk-auto-mnemonics = 1

в настройках вашей темы: /usr/share/themes/YOUR_THEME_NAME/gtk-3.0/settings.ini


0
2018-02-06 09:43



Редактирование установленной темы из / usr / share / themes является идеей BAD - поскольку изменения будут перезаписаны при установке нового пакета - Vadim Rutkovsky