Вопрос Интеграция Eclipse / Java не работает после обновления Ubuntu 12.04


Сегодня утром я добрался до Ubuntu 12.04. После обновления я включил Eclipse и заметил, что в нем не хватает интеграции Java: перспективы Java пропали, отсутствует возможность создания нового Java-проекта, элемент меню для создания существующих проектов Java был выделен серым цветом и т. Д. Все работало нормально перед обновлением.

:~$ echo $JAVA_HOME
/usr/lib/jvm/default-java

:~$ which java
/usr/bin/java

Если я могу предоставить дополнительную полезную информацию, пожалуйста, дайте мне знать. Я все еще относительно новичок в мире Linux / Java, поэтому заблаговременно за помощь.


8
2018-04-29 23:18


происхождения


пакеты eclipse претерпели значительные изменения между 11.10 и 12.04. попробуйте удалить eclipse ppa и переустановить eclipse из программного центра. меня устраивает. если вы хотите, чтобы java-материал также установил пакет pde - RobotHumans
Я попытался удалить / установить Eclipse через Software Center, и он ничего не изменил, но не интегрировал Java. Можете ли вы пояснить, что вы подразумеваете под пакетом PDE? Что-нибудь еще, что я могу пропустить? - Tyson Trautmann
это: i.imgur.com/nMRgS.png - RobotHumans
Ах, гоча. Спасибо, что указали, что я установил обновление до 12.04, но не переустанавливал его. Мне действительно удалось заставить это работать по-другому, я просто схватил последний Eclipse JEE (хотел все равно) от eclipse.org/downloads/moreinfo/jee.php и опустил содержимое в / usr / lib / eclipse, и все, похоже, работает из коробки. Наверное, я не уверен, что это приведет к автоматическому обновлению Eclipse через Software Center. - Tyson Trautmann
Похоже, что это был плохой вызов, теперь я не могу установить новое программное обеспечение из Eclipse (я получаю всплывающее окно, в котором говорится, что установка не была правильно настроена для обновлений программного обеспечения). - Tyson Trautmann


ответы:


Eclipse - чрезвычайно «чувствительная к версии» экосистема платформы.

Я использую eclipse в течение 9 лет, начиная с эпохи 2.x. Почти каждый плагин, который я использовал, должен был быть установлен с точная версия его зависимостей, любые незначительные вариации, и результат был нестабильной IDE на всем протяжении.

Если вы собираетесь программировать в JEE, я настоятельно рекомендую использовать загруженный с сайта Eclipse, когда это возможно, устанавливать плагины через средство обновления eclipse. Вы будете жить дольше и счастливее :)

Я разработчик JEE в течение последних 6 лет, и каждый раз, когда я пытался использовать Eclipse из репозитория, результат был ужасным, слишком много нестабильности, и многие плагины не работали должным образом (например, Jboss Tools).

В последнее время у меня были некоторые проблемы с запуском JBossWS с версиями 3.7.x, он часто разбивался на 64Bit, Mint 12 (Ubuntu 11.10), поэтому я решил перейти на Eclipse 3.6.


3
2018-05-11 03:57