Вопрос Проблема яркости в Lenovo ThinkPad Edge LR236W5


После обновления с 13.04 до 13.10 Яркость не работает. Пожалуйста, дайте мне знать, как решить эту проблему,

Конфигурации машин приведены ниже.

id: thinkpad
description: Notebook
product: 0301G8G ()
vendor: LENOVO
version: ThinkPad Edge
serial: LR236W5
architecture:   64 bits

6
2017-10-21 15:40


происхождения


Отлично работает для меня! Благодаря!! Подробности: Машина: SAMSUNG Laptop (NP-R428) ОС: Ubuntu 13.10 Изменение сделанное в / etc / default / grub: GRUB_CMDLINE_LINUX_DEFAULT = "тихий всплеск" в GRUB_CMDLINE_LINUX_DEFAULT = "тихий всплеск acpi_backlight = vendor" sudo update-grub Перезагрузка. Работал как шарм !!! Благодаря!!


ответы:


Вы пробовали это:

  • Открытый терминал ( Ctrl+Alt+T ) и введите:

    sudo cp /etc/default/grub /etc/default/grub.bak
    sudo gedit /etc/default/grub
    

    Вы увидите эту строку в новом открывшемся окне: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

  • Измените его на:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
    
  • Сохраните и закройте окно и введите его в терминал:

    sudo update-grub
    
  • Перезагрузите систему.

если вышеуказанная процедура не работает, повторите тот же шаг, но на этот раз попробуйте изменить указанную выше строку следующим образом:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force"

Заметка: Следующая строка, указанная выше, должна быть GRUB_CMDLINE_LINUX="" не GRUB_CMDLINE_LINUX="acpi_osi=Linux"


8
2017-10-21 21:41



Вариант один работает отлично. Благодарю. - kds


Я думаю, вы пытаетесь использовать горячую клавишу ThinkPad. Вы можете попытаться настроить параметр Яркость и Блокировка в Системных настройках, потому что, возможно, драйвер не работает должным образом.


0
2017-10-21 15:48



Я пробовал оба варианта, которые не работают. Обратите внимание, что я также установил Gnome 3.8. - kds


Я написал образец сценария, основанный на диалоговом окне bash, чтобы изменить яркость моего ноутбука, пока они не исправят это в 13.10.

Здесь выше ссылка на источник на github: https://github.com/kjpopov/Ubuntu-Useful-Scripts/blob/master/choose_brightness

Вы можете отредактировать его, чтобы добавить больше значений, а также вы можете изменить строку 33, чтобы она работала для вашего видеоадаптера.

Я использую ноутбук Asus X55U с Radeon HD 6290

Убедитесь, что вы выполняете сценарий как привилегии суперпользователя (root).

С наилучшими пожеланиями!


0
2017-10-29 07:12



Пожалуйста, не отправляйте повторяющиеся ответы на разные вопросы. Это просто создает больше работы для модераторов. Если вопросы настолько похожи, что один и тот же ответ работает на каждого, то более поздний из них, вероятно, является дубликатом и должен быть помечен как таковой. - RolandiXor♦


Попробуйте в терминале:

apt-get update
apt-get install brightness-controller

0
2017-11-13 04:44



Невозможно найти - Aaron Schif


1) Решение для управления яркостью для графики Intel в Ubuntu 13.10: Еще одна попытка попробовать создать файл /usr/share/X11/xorg.conf.d/20-intel.conf со следующим содержанием:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

2) Решение для экономии яркости для графики Intel в Ubuntu 13.10: В команде терминала:

cat /sys/class/backlight/intel_backlight/max_brightness

Максимальная максимальная яркость составляет 976, минимум 0. Запустите следующую команду в терминале:

sudo gedit /etc/rc.local

Добавьте следующую строку перед последней строкой:

echo [value] > /sys/class/backlight/acpi_video0/brightness

где значение находится между 0 и макс. Помните, никогда не устанавливайте 0, потому что 0 - черный экран!


0
2018-01-05 22:36





Такая же проблема сохраняется в 14.04 LTS, Как только вышеуказанные шаги будут выполнены, это работает нормально.

sudo cp /etc/default/grub /etc/default/grub.bak
sudo gedit /etc/default/grub

Вы увидите эту строку в новом открывшемся окне: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Измените его на:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Сохраните и закройте окно и введите его в терминал:

sudo update-grub

0
2018-04-23 04:22





У меня возникла та же проблема с значениями яркости, которые не сохраняются при перезагрузке компьютера после обновления до 13.10.

Раньше я использовал скрипт python для установки желаемой яркости, скрипт был настроен как приложение для запуска. Я получил его откуда-то на этом форуме. Сценарий также больше не работает, поскольку значение gconf больше не похоже на Gnome 3.8.

Я решил проблему, установив утилиту xbacklight. Я добавил к моему запуску следующее:

xbacklight -S 20


0
2017-10-21 21:44



должно быть xbacklight -set 20 - rubo77