Вопрос Vino VNC Server не может запускаться при запуске


Поэтому я пытаюсь запустить Vino VNC Server при загрузке, то есть мне не нужно входить в систему, чтобы запустить VNC-сервер. Я на Ubuntu GNOME 15.04, и я уже добавил

/usr/lib/vino/vino-server

к «Запуск приложений». Тем не менее, сервер VNC по-прежнему не запускается, как только я загружаюсь. Мне нужно войти в систему, чтобы запустить VNC-сервер. Что мне делать? Мне нужно создать файл systemd? Если да, то как мне это сделать?

редактировать: Этот вопрос отличается от это потому что мне нужен Vino Server для работы, в то время как это руководство предлагает x11vncserver.


6
2018-06-14 09:03


происхождения


возможный дубликат Как запустить сервер VNC перед входом в систему? - Mark Kirby
@markkirby Я отредактировал сообщение о том, почему мой пост отличается, также, предложение автоматического входа в систему не является чем-то, что я могу рискнуть. - The Man
Я тоже хотел бы знать, как заставить Vino начать загрузку. - Matt
Посмотри на эти ответы здесь - Robert Riedl


ответы:


создать системный блок или службу для запуска vino-сервера при запуске

  1. cd /etc/systemd/system/
    
  2. sudo vim vinostartup.service
    
  3. [Unit]
    Description = description about the service
    After = network.target
    [Service]
    ExecStart = /usr/lib/vino/vino-server
    [Install]
    WantedBy = multi-user.target
    
  4. Включить службу

    sudo systemctl enable vinostartup.service
    
  5. Проверьте его, используя команду vinostartup.service.

    ls multi-user.target.wants/
    
  6. Если вы не хотите ждать следующей загрузки (она уже включена), мы можем запустить службу

    sudo systemctl start vinostartup.service
    

2
2018-03-01 05:43



Спасибо, но не работает, к сожалению :( - Matt


Должен иметь SSH и root доступ к серверу, затем SSH к нему с использованием обычной учетной записи пользователя и редактировать файл /etc/gdm3/custom.conf, в результате чего следующие строки в разделе [daemon] выглядят следующим образом:

AutomaticLoginEnable=true
AutomaticLogin=yourusername

Сохраните и перезагрузите сервер, запустив «sudo shutdown -r now». Как только gdm перезагрузится, он автоматически войдет в систему как указанный пользователь, и затем начнется процесс vino-server, так что вы снова сможете VNC в систему. Не забудьте удалить эти строки автозапуска из файла /etc/gdm3/custom.conf, когда закончите.

Отредактировано https://encodable.com/tech/blog/2009/03/02/How_To_Access_A_VNC_Remote_Desktop_After_The_Server_Reboots


0
2018-03-06 15:00





vino-server не мог начаться с systemd успешно, он будет искать зеркальный сервер и вернуть ошибку сокета на мой рабочий стол ubuntu. Похоже, разработчики gnome недавно добавили параметр systemd для компиляции проекта
Правильный способ сделать это - использовать Запуск приложения в вашем настольном дистрибутиве
Найдите программу автозапуска yout distro здесь Страница архивирования archlinux база на вашем собственном рабочем столе

Ниже приведены полные инструкции по настройке сервера vino 

Например: я использую рабочий стол xfce
 Перейдите к: Пуск-> Меню приложений-> Настройки-> Сессии и Запуск-> Автозапуск приложения и найдите «Рабочий стол» и включите его, или вы можете просто добавить /usr/lib/vino/vino-server к нему

До этого вам, возможно, придется настроить сервер vino
У меня нет панели настроек gnome на рабочем столе xfce, поэтому я запускаю

$ vino-preferences

от терминала, чтобы настроить настройку соединения

Возможно, вам придется отключить шифрование, чтобы клиенты vnc могли подключаться к компьютеру

$ gsettings set org.gnome.Vino require-encryption false

перезапустить и сделать


0
2017-09-17 13:28





Я думаю, вы можете пойти Центр управления, тогда Запуск приложения и добавьте новый элемент с помощью команды:

/usr/lib/vino/vino-server &

-1
2018-04-12 03:01