Вопрос Странный шум в наушниках, когда звук не воспроизводится


Странный шум от моих наушников на Lenovo T440. Звук похож, когда вы настраиваете радио, но вы получаете неправильную частоту, и вы слышите неприятный шум. Шум начинается, когда Ubuntu 14.04 загружается и заканчивается после выключения. Он выходит только через наушники, в динамиках нет шума.

Странно то, что шум исчезает при воспроизведении какого-либо звука или при вводе звуковых предпочтений. Но когда звук остановлен, он появляется снова через 10 секунд или меньше. Кроме того, шум идет вниз (или может даже исчезнуть), если я поставлю зарядное устройство для ноутбука и остановлю музыку.

Независимо от того, как я меняю уровень громкости, уровень шума тот же. Похоже, что выход не отключается после остановки звука.

sudo aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA Intel HDMI], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 7: HDMI 1 [HDMI 1]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: HDMI [HDA Intel HDMI], device 8: HDMI 2 [HDMI 2]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC292 Analog [ALC292 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0

29
2018-04-29 20:20


происхождения


im на lenovo t440s, и этот вопрос недавно произошел с моей установкой 14.04. как ни странно, моя догадка заключается в том, что это произошло после того, как я изменил некоторые параметры, связанные с / etc / x11 / mouse, и затем перезапустил lightdm. никогда не было проблемой в прошлом, а теперь и повсеместно. - faith_in_facts
Проблема исчезла после того, как я сменил beep канал в alsamixer из 0 на что-то еще и обратно 0 - EECOLOR
Возможный дубликат Плохой старый шум в наушниках на Ubuntu 16.04 LTS - Logan
реверсивное направление (голосование, чтобы оставить это открытым), поскольку в этом посте больше ответов и ответов - Zanna


ответы:


Аналогичная проблема возникла и в Dell XPS15 (модель 9550, 2015 в Xenial). Разрешил его в alsamixer и заглушил петлевой канал.

$ alsamixer

Переход на loopback (весь путь направо, с  ) и установите Disabled используя  ключ.

  • Не требуется перезагрузка;
  • Нет необходимости в корне;
  • Насколько я заметил.

25
2017-08-15 16:53



Это решение работало на моем Dell Precision 5510. - dmiller309
Это также работало на моем Dell Precision 5510. Спасибо! - L42
Это отлично работает на Dell - Maduka Jayalath
Работает на Lenovo y700. У меня возникла проблема с шумом с динамиками, а не с головным телефоном. Метод save_ audio не работает в моем случае - alphabetagamma
С помощью этого метода вы также можете включить питание и, таким образом, сохранить батарею. - JonasCz


У меня была та же проблема на Dell Inspiron 3542 с Ubuntu 14.04.2

Проблемы, как представляется, находятся в функции аудиопотока.

Шум останавливается при открытии настроек звука или при воспроизведении аудио / видео. Шум начинается снова, когда я перестаю воспроизводить аудио / видео и закрываю настройки звука.

Это решение работало для меня: Редактировать файл

$ sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave

изменить линию

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

в

INTEL_AUDIO_POWERSAVE=false

Перезагружать.

После этого я не стал больше беспокоиться.


12
2018-04-26 02:17



Работала отлично для меня, Xenial на Dell XPS 13 9350 - Robin Winslow
любые идеи, почему энергосбережение вызывает эти странные звуки? Это не экономия энергии. Мне просто интересно! - Surya Teja Karra
sudo aplay -l дает мне аналогичный результат. Я использую Dell Inspiron 15 3542. У меня нет файла «intel-audio-powersave». Могу ли я создать его? - Logan
Возможно, вам нужно выбрать правильную звуковую карту, сначала используя F6 - Alex0007
Ты такой потрясающий !!! Работал на моем Macbook 2006 Позднее работает только Ubuntu 16.04 LTS :) - yanike


Возможно, ваш аудиоинтерфейс переходит в режим энергосбережения.

Если следующие команды устраняют проблему, пока вы не перезагрузитесь или не измените источник питания, у нее есть что-то делать с энергосбережением:

echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save_controller
echo 0 | sudo tee /sys/module/snd_hda_intel/parameters/power_save

7
2017-10-09 13:02



Благодаря! Это работает на других дистрибутивах ;-) В моем modprobe.conf у меня появилось что-то вроде «options snd_hda_intel power_save = 0 power_save_controller = 0» - Lester Cheung
Отлично работает для меня, Xenial на Dell Inspiron 14 7000 - Ren
Продолжает работать с 18,04 LTS (бионический). - Kyle Barbour


Я была такая же проблема. Я считаю, что это шум, который ваш микрофон поднимает.

Войти в Sound Settings, под Input вкладка, проверка Mute рядом с Settings for <microphone_name> Microphone (Не Mute флажок вверху).

enter image description here

Это должно делать свое дело.


5
2017-10-09 12:50



Следуя инструкциям, мои наушники не работают. - Tianren Liu
Для меня на Dell M3800 это не имело никакого эффекта. - Garrett
микрофон обычно не воспроизводит динамики, если вы не запускаете pactl load-module module-loopback latency_msec=1 - mchid
Это сработало для меня. Отключение микрофона удалило весь шум. Спасибо. - Hussein El Motayam
Это сработало. Может кто-нибудь объяснить, почему это работает? - Parag Gangil


У меня была точно такая же проблема, и ни один из вышеперечисленных методов не работал для меня.

Мой ноутбук - ASUS ROG-G501JW, а звуковая карта - Realtek.

Я нашел решение в этой теме: Белый и шипящий шум в наушниках, не присутствующих в Windows,

Установка этой строки в /etc/modprobe.d/alsa-base.conf исправлены все мои проблемы:

options snd-hda-intel model=dell-headset-multi

3
2018-01-09 21:19





У вас активирован tlp?

Если так редактировать / etc / default / tlp и установите значения параметра энергосбережения равным 0

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

это сделало трюк для меня


2
2018-05-09 02:48



На моем Dell M3800 я попытался настроить SOUND_POWER_SAVE=0, но это не помогло ... - Garrett


У меня была эта проблема на Dell 3542 с Ubuntu 16.04 GNOME, и она началась, когда я установил TLP для экономии энергии. Поэтому после того, как я увидел здесь, что проблема связана с энергосбережением, я просто удалил TLP, и проблема исчезла.


0
2017-11-06 13:12





У меня была эта проблема на Asus X200ca с ElementaryOS Loki (Ubuntu 16.04) и другим дистрибутивом linux, который я использовал. Я исправил проблему с

  • бег alsamixer (не в режиме sudo)
  • Перейдите к Auto-mute Mode (используя стрелку вправо)
  • Измените его, чтобы включить (используя стрелку вверх)

Теперь у меня опять нет проблемы.


0
2018-01-23 08:08





Я нашел необычную причину моего чрезмерного фонового шума ... моя Цивилизация 5 (работающая через Steam) не выходила должным образом. Фоновый шум, который я слышал, был из игры. Я использовал «htop», чтобы найти и убить все процессы Civilization и, конечно же, шум уменьшался каждый раз, когда я убивал процесс из игры.

Так что не проблема Ubuntu и звука; это было фактически одно конкретное приложение (которое никогда не выходит из строя в любом случае).


0
2017-11-18 21:36