Вопрос Установите gcc 4.9 на ubuntu 18.04


Есть ли способ установить gcc 4.9 на ubuntu 18.04? Я пытался

sudo add-apt-repository ppa:ubuntu-toolchain-r/ppa
sudo apt-get update
sudo apt-get install gcc-4.9 g++-4.9

но я получаю Package g++-4.9 is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source Мне нужна эта версия для запуска некоторых симуляций со снайпером. Нужно ли это сделать, или мне нужно создать виртуальную машину с помощью ubuntu 16.04?


4
2018-05-14 12:58


происхождения


Измените свой вопрос, чтобы объяснить, зачем вам нужна версия gcc 4.9 - Knud Larsen
@KnudLarsen Это очень неуместно. - Jon Deaton


ответы:


Доступно: sudo apt install g++-4.8

И нет PIE  gcc54-c++_5.4.0-ubuntu16_amd64.deb  https://drive.google.com/file/d/1ptHLaZXImpeMzq4xuuGGn5VjrvxNSop3/view?usp=sharing , Ссылка  https://stackoverflow.com/questions/50213089/linking-error-with-gcc-g-7-3-0-on-ubuntu-18-04/50232797#50232797 → Мой ответ.

Или добавить xenial в /etc/apt/sources.list временно: sudo gedit /etc/apt/sources.list

deb http://dk.archive.ubuntu.com/ubuntu/ xenial main
deb http://dk.archive.ubuntu.com/ubuntu/ xenial universe

... и делай sudo apt update && sudo apt install g++-4.9


5
2018-05-14 14:42



Вы очень благодарны. Думаю, что если бы 4.9 было недоступно, то это было бы с 4.8. - Nikos Tzagarakis
Вы всегда можете использовать $ apt-cache search g++ g++-4.8 ... а также использовать онлайн-страницу «Поиск и обзор» packages.ubuntu.com/search?keywords=g%2B%2B&searchon=names - Knud Larsen