Вопрос Не удается войти в Ubuntu 16.04 после обновления


Я установил Ubuntu 16.04 (двойная загрузка с Win 10), и он не заходил после. Я обновился с Ubuntu 15.10 через update-manager

https://youtu.be/MrgPYvoVJfA

Я пробовал старые обходные пути для предыдущих версий, например:

  • dpkg-reconfigure lightDM
  • chown user:user .Xauthority
  • chmod 666 .Xauthority
  • chmod a+wt /temp
  • mv .Xauthority smth
  • apt-get install ubuntu-session
  • Переустановка драйверов Nvidia

Любые предложения appre


28
2018-04-21 09:53


происхождения


Сброс конфигурации Unity. Как: askubuntu.com/questions/17610/...
@Squirrel, извините ((но не помогает unity --reset - Jasorgho
Они продолжают отмечать их как дубликаты, но старое решение не работает. Я уничтожил свою систему, потому что я устал и узнал, что она связана с проблемами сторонних драйверов вместе с безопасной загрузкой. Тем не менее, havnt выяснил это. Сообщили тонну ошибок, не были одиноки, поэтому я надеялся, что это будет исправлено в ближайшее время. - jargonjunkie
Возможный дубликат Почему я устанавливаю «Необходимый ключ недоступен» при установке модулей DKMS в Ubuntu 16.04? - Pilot6
Какое ядро ​​вы используете? У меня возникла проблема, когда я использовал ядро ​​4.6.0-rc5. Благодарю. - Xiaodong Qi


ответы:


Я был в той же ситуации, что и вы.

Я не переустанавливал драйверы nvidia, но удалял его.

sudo apt-get purge nvidia*

И это сработало.


32
2018-04-22 10:49



Я сделал то же самое, и это сработало. Но, вы знаете, это не окончательное решение, если вы хотите использовать второй монитор с поддержкой карт nVidia! - Xiaodong Qi
не работает для меня - Jasorgho
Это просто сработало для меня. Благодаря! - Piero Divasto
Ты спас мой день в ноябре :) - Jacob Vlijm
Это решение работало для меня несколько. Он решил мою непосредственную проблему, но на самом деле это не окончательное решение проблемы. Я также не могу запустить gdm3 с этим изменением, но теперь работает lightdm. Реальная проблема, по-видимому, является несовместимостью между новыми ядрами и драйверами nvidia (которые отлично работали для меня до того, как я сделал обновление). Мне грустно, что это было не лучше проверено до того, как оно было выпущено, и что оно еще не исправлено. - Tom Karzes


На всех моих системах (у всех была такая же проблема) решение было:

  • Переключитесь на консоль с помощью Ctrl + Alt + F1
  • Войдите в текстовую консоль (ваше имя пользователя достаточно, если ваша система имеет только одного пользователя, иначе вам понадобится root-пользователь или sudo)
  • rm /home/*/.Xauthority
  • reboot

6
2017-08-10 10:29



Это помогло мне (спасибо), но это не то, о чем попросил ОП (он перечислил, что он уже сделал mv .Xauthority smth - Carlo Wood
@smth Разница в том, что ОП только отодвинул .Xauthority одного пользователя ... - Daniel Alder
Это легко работало для меня, не прибегая к другим предложениям, связанным с удалением или переустановкой компонентов. - matt


Я столкнулся с той же проблемой при обновлении до 16.04 с 15.10. Я напомнил, что во время обновления было предложено указать параметры безопасной загрузки UEFI. Я проверил свои настройки BIOS и, конечно же, в «Безопасной загрузке» был установлен «Только для Windows». Я выбрал «Other OS» из списка (ваши варианты могут быть разными) и загрузился нормально. Все исправлено.

Не видели никаких других упоминаний об этом исправлении, поэтому, надеюсь, это поможет.


3
2018-04-23 15:36



Я хотел бы подтвердить, что он также исправил мою проблему. Была модернизация новой Dell Precision с 14.04 по 16.04, и в настройку я отключил Безопасную загрузку, и она сработала. - Salketer


У меня есть эта проблема. Эта проблема связана с новым совпадением Unity с 4.4.0 версию ядра и версию ядра, такую ​​же, как 4.2.x теперь у вас есть 2 решения для этой проблемы:

  1. temp: установите другой рабочий стол, также как и gnome,lxde, или т.д ...
  2. или обновить ядро.

для запуска команды до или после цикла Ctrl+альт+F1:

для проверки версии ядра: отправьте эту команду

$ uname -a 

и ядро ​​fore update:

http://ubuntuhandbook.org/index.php/2016/01/how-to-install-linux-kernel-4-4-in-ubuntu/

для установки другого настольного env googling о вашем рабочем столе env.


1
2018-04-26 07:07



Я использую ядро ​​Linux 4.6.0-rc5 и GNOME 3.20.1, но все еще испытываю проблему. Мысли? - Xiaodong Qi
Попробуйте установить elementary-desktop  для фиксации: askubuntu.com/questions/529715/... - A1Gard


Я просто попробовал идею Nuno .. Отрицательный для меня .. все еще застрял в цикле регистрации на Console-7 .. Но, смог войти в систему через консоль 1 (TTY1) .. Я также столкнулся с этим назад, когда я пошел по маршруту 12.10 до 13.x (оба), и он приземлился в том же цикле. Только обходной путь, который я мог найти, использовал старый список «Установленный» из Synaptic, выполнив новую установку 13.04, а также выполнив то же самое, когда i натолкнулся на 15.04. , получив Synaptic загруженный 1-й, а затем прочитав в старом списке программ.


0
2018-04-22 19:02



просто попробовал другую идею, и этот РАБОТАЕТ! Войдите в систему через TTY1 .. Теперь введите следующее: [code] sudo mv .Xauthority .xAuthority.old [/ code] перезагрузитесь, и это сработало! - Stephen Griswold
Видимо, я пропустил шаг .. Он также требует повторной установки LightDM с нуля. [Code] sudo apt-get purge lightdm; sudo apt-get install lightdm -y [/ code], а также удаление всех драйверов nvidia ... (вставьте подголовник низкий ..) - Stephen Griswold