Вопрос Не удается установить драйверы для моей карты Realtek rtl8723be wifi в Ubuntu 16.10


Пытался

$ sudo add-apt-repository ppa:hanipouspilot/rtlwifi
$ sudo apt-get update
$ sudo apt-get install rtlwifi-new-dkms linux-firmware

Но давая 

whiplash@whiplash-HP-Notebook:~$ sudo apt-get install rtlwifi-new-dkms    
Reading package lists... Done    
Building dependency tree           
Reading state information... Done    
E: Unable to locate package rtlwifi-new-dkms

Информация о моей беспроводной карте:

*-network
       description: Wireless interface
       product: RTL8723BE PCIe Wireless Network Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 00
       serial: a8:a7:95:23:cb:25
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8723be driverversion=4.8.0-27-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:17 ioport:3000(size=256) memory:a1100000-a1103fff

4
2017-11-26 06:54


происхождения


Как я вижу Вот пакет rtlwifi-new-dkms недоступен для Ubuntu 16.10 (Yakkety). Последняя версия Ubuntu, поддерживаемая этим репозиторием PPA, - 16.04 (Xenial). Я думаю, вы должны скачать пакет для Ubuntu 16.04 и заставить dpkg для его установки. Будьте осторожны с этим решением. Может быть, это dpkg база данных! - SuB
У вас уже есть драйверы для вашего Wi-Fi, есть ли проблемы? - Jeremy31
Как говорит @ Jeremy31, у вас уже есть водитель. Установка старшая версия, не написанная специально для вашей версии ядра, вряд ли поможет. Расскажите, пожалуйста, какие у вас проблемы. - chili555
Проблема в том, что я должен сидеть очень близко к маршрутизатору, иначе из-за слабой силы сигнала я не могу подключиться к Wi-Fi. Проблема заключается в слабой мощности сигнала - Stonecipher
Вы можете создавать драйверы вручную, следуя инструкциям, указанным в ответе на этот вопрос askubuntu.com/questions/590414/... Я успешно пробовал их в Ubuntu 16.10. - coolbootgeek


ответы:


Я поддерживаю hanipouspilot Через поверенного Вот почему я могу дать лучший ответ ;-)

Я не загружал rtlwifi-new-dkms пакет для Якеты 16.10.

Вы можете попробовать загрузить deb для Xenial, но маловероятно, что он будет строить для ядра 4.8. Я не проверял.

Причина проста. Я не использую этот выпуск, и я не могу протестировать модуль.

Вы можете попробовать использовать драйвер из https://github.com/lwfinger/rtlwifi_new


1
2017-11-26 12:17



Собираетесь ли вы скоро загрузить Яккеты 16.10? - Stonecipher
Или мне нужно вернуться к 16.04 LTS? - Stonecipher
Я не планировал поддерживать яккеты в своем PPA. Вероятно, я сделаю это некоторое время, но никаких обещаний. - Pilot6