Вопрос Как установить Flash-плеер на Ubuntu?


Несмотря на то, что у меня есть последний Adobe Flash Player 11.2 для Linux в Firefox - ref: Угрозы безопасности Flash-плеера - конкретная онлайн-флеш-игра по-прежнему запрашивает обновление до последнего флеш-плеера.

Я пробовал эту онлайн-игру на своем ноутбуке (Windows 8 с Flash Player 11.8), и у нее нет проблем.

Есть ли способ обмануть Ubuntu или эту игру, думая, что Flash Player 11.8 «установлен»?


123
2017-09-04 20:23


происхождения


Поскольку вы уже знаете, что последний флеш-плеер для Linux 11.2.x, Поэтому я рекомендую вам использовать Latest Google Chrome Browser. Он уже поставляется со встроенным последним флеш-плеером. Не нужно устанавливать флеш, пока вы просматриваете интернет. ;) Загрузить chrome отсюда: google.com/intl/en/chrome/browserОтвет, если вам нужна дальнейшая помощь. - Saurav Kumar
Связанный: askubuntu.com/questions/562271/... - Ben
См. Мой ответ здесь; askubuntu.com/a/908985/682596 - Roel


ответы:


Примечание. Этот ответ сильно устаревший, Пожалуйста, обратитесь к ответ Кареля вместо этого описывается, как Canonical и Adobe в настоящее время рекомендуют установить Flash Player в Ubuntu.


Для Linux последняя версия Загрузить Adobe Flash Player это 11.2, которое у вас уже есть. Извините, но он не может быть обновлен до 11.8. Adobe предоставляет резервные копии безопасности для Flash Player 11.2 для Linux.

Чтобы установить подключаемый модуль Flash Ubuntu 13.04 (Raring Ringtail), пожалуйста, следуйте этому процессу:

  1. Включить multiverse хранилище, как показано ниже: Как включить репозиторий «multiverse»? 

  2. Откройте окно терминала (нажмите Ctrl+Alt+T) и скопируйте / вставьте эту строку:

    sudo apt-get install flashplugin-installer 
    
  3. Когда Flash Player установлен, закройте окно терминала и перезапустите браузер.


133
2017-09-04 20:34



..и с тех пор flashplugin-installer имеется в Мультивселенная хранилище, вам может потребоваться включить репо. ..также эта ссылка должна помочь: Как включить репозиторий «multiverse»? - precise
Это также работает 14.04. - dusan
Этот метод работает и для 15.04. :) - Muhamed Huseinbašić
Этот метод также работает для 15.10. - galath
Установлено, но chrome://plugins в Chromium я не вижу вспышки ... Lubuntu 15.10 - Vitaly Zdanevich


Чтобы установить последнюю версию флеш-плеера, найдите Dash (в версиях Ubuntu до 17.10) или панель инструментов «Показать приложения» (в Ubuntu 17.10 или новее) для «Программное обеспечение и обновления» и откройте окно «Программное обеспечение и обновления». Нажмите Другое программное обеспечение в окне «Программное обеспечение и обновления» и поставьте галочку в поле слева от места, где указано: Канонические партнеры,

enter image description here Программное обеспечение и обновления в Ubuntu 17.10

Нажмите Закрыть чтобы закрыть окно «Программное обеспечение и обновления».

Откройте терминал и введите:

sudo apt-get update   
sudo apt-get install adobe-flashplugin  

19
2017-12-30 22:39



Лично я думаю, что это должен быть единственный ответ, и остальные ответы (которые в основном устарели) удалены. - Gunnar Hjalmarsson
Какая строка APT вводится после нажатия кнопки «Добавить»? - Code-Guru
sudo apt-get update && sudo apt-get install adobe-flashplugin - karel
@karel: Я думаю, что это то, что Code-Guru в приведенном выше комментарии находило смущение, потому что нажатие этой кнопки «Добавить» вызывает всплывающее окно с запросом URL-адреса APT. - Nicolas Raoul


Adobe больше не предоставляет обновления Flash Player для Linux, за исключением резервных копий безопасности.
Из Блог Abobe Flash:

Для выпусков Flash Player после 11.2 плагин для браузера Flash Player для Linux будет доступен только через API «Pepper» в рамках распространения браузера Google Chrome и больше не будет доступен для прямой загрузки из Adobe. Adobe продолжит предоставлять обновления безопасности для не-перечных дистрибутивов Flash Player 11.2 на Linux в течение пяти лет с момента ее выпуска.

Вы можете использовать последнюю вспышку в Гугл Хром или хром Install chromium-browserс плагином «Pepper Flash»

Adobe Flash Player напрямую интегрирован с Google Chrome и включен по умолчанию. Доступные обновления для Adobe Flash Player автоматически включаются в обновления системы Chrome.

Вам нужно будет установить его вручную в Chromium, глянь сюда


15
2017-09-04 20:43



Больше неправда. Версия PPAPI по-прежнему поддерживается. - Evan Carroll
pcworld.com/article/3116409/linux/... кажется, указывает, что этот ответ больше не верен - Mateusz Konieczny


К сожалению, Adobe отказалась от поддержки версии Flash Player GNU / Linux (хотя обновления по безопасности все еще предоставляются). Однако есть еще два способа получения более новых версий.

Первое - запустить версию Windows через Вино, слой эмуляции программного обеспечения, предназначенный для работы программного обеспечения Windows в GNU / Linux и других Unix-подобных системах. Вам понадобится веб-браузер Windows (например, версия Windows Fire Fox), с версией Windows Flash Player.

Или вы можете установить Гугл Хром, поскольку он всегда имеет последнюю версию Flash, даже на Ubuntu. Если вы выберете Chrome, вам не понадобится Wine. Это больше не может быть вариантом. См. Обновление №3.

Обновить: Теперь я знаю третий способ сделать это: Pipelight! Pipelight первоначально был плагином браузера, предназначенным для использования вилки WINE для запуска Microsoft Silverlight. Однако в какой-то момент разработчики решили добавить поддержку Flash. Видеть Вот инструкции по установке Pipelight и включению Flash Player.

Однако этот метод не является совершенным; если вы обнаружите, что ваш браузер не будет реагировать на вашу мышь, вы можете либо переключить рабочие области (используя ярлыки клавиатуры на рабочем столе), либо переключить окна (снова сочетания клавиш). В любом случае, когда вы переключаетесь назад, вы должны снова нажать. Обратите внимание: я тестировал это только с помощью Linux Mint's корица рабочий стол (который разветвляется у Gnome) и не может гарантировать, что это будет работать на других рабочих столах. Если все остальное не удается, вы можете переключиться на tty и убить pipelight, используя pkill pluginloader.exe,

Кроме того, вы можете запустить sudo pipelight-plugin --update время от времени, так что Pipelight будет знать, чтобы установить обновленную версию flash-плеера. Это предотвращает попытки Pipelight загружать плагины из мертвых ссылок и гарантирует, что плагины остаются в курсе последних событий. Или вы можете создать файл cron для автоматического запуска команды. Для этого запустите sudo bash -c 'echo -e \#\!"/bin/bash\n\npipelight-plugin --update" > /etc/cron.weekly/pipelight-update; chmod a+x /etc/cron.weekly/pipelight-update' Это позволит обновлять список плагинов Pipelight еженедельно, хотя плагины actall не будут обновляться до тех пор, пока вы не запустите браузер на основе NPAPI.

Обновление 2: Я нашел еще один плагин который использует Pepper (Google Chrome) Flash Player внутри других браузеров (например, firefox). Этот плагин, известный как freshplayerplugin, является родной версией Flash, поэтому WINE не требуется. Обратите внимание: хотя я не пробовал этот метод, у Pepper Flash, как известно, есть проблемы с видео с защитой DRM, например, на Amazon Prime. Если вы просматриваете видео с защитой DRM с помощью Flash Player, вы можете использовать Pipelight.

В приведенной выше ссылке рассказывается, как установить FreshPlayerPlugin путем клонирования git-репозитория и компиляции кода самостоятельно. Или вы можете установить пакет pepflashplugin-installer из skunk / pepper-flash ppa: sudo add-apt-repository ppa:skunk/pepper-flash && sudo apt-get update && sudo apt-get install pepflashplugin-installer, См. Нижнюю часть ЭТО чтобы узнать, как включить Chromium для использования pepperflash. Внимание: это зависит от поддержки Google Chrome. См. Обновление №3,

Обновление 3: Google отказался от поддержки Chrome для всех 32-разрядных систем GNU / Linux. Если у вас 64-битная система, вы можете использовать Chrome как обычно. В противном случае вам придется либо запустить старую версию Chrome (удачи, находящей ее. Также следует предупредить, что старые браузеры не защищены), переключиться на 64-разрядную систему или попытаться запустить версию Windows через WINE. Поскольку 32-битные системы больше не поддерживаются, вы больше не можете использовать метод, описанный в обновлении №2, в 32-разрядных системах.

Обновление 4: Pipelight был прекращен автором. Вы уже не можете установить с ним Flash Player. Тем не менее, Adobe решила поднять версию Flash Player GNU / Linux до последних версий, поэтому, я думаю, вам не нужен pipelight или freshplayerplugin. на самом деле, этот тип делает весь этот ответ устаревшим.


11
2017-09-04 20:44



да, на стороне записки, adobe являются членами. google заплатил создателям вина, чтобы оптимизировать фотошоп на linux, разве это не приятно? вместо этого adobe возвращает их, останавливая поддержку воздуха, считывателя и вспышки на Android и Linux. но это нормально, потому что скоро html5 возьмет на себя - Nick Bailuc
К сожалению, плагин freshplayer просто обертывает перечную флешку с интерфейсом NPAPI, чтобы Firefox мог его использовать. Pipelight также является плагином NPAPI. Но Firefox отказывается от поддержки NPAPI к концу года, Есть ли еще одно решение для Flash в Firefox, которое еще не планируется убить или переключение на Chrome / running под Wine действительно является единственным вариантом? - Ben
Flash не отказался от поддержки версии PPAPI, здесь доказательство: он также упакован и доступен для Ubuntu, см. Мой ответ здесь, - Evan Carroll
на самом деле, этот тип делает весь этот ответ устаревшим. - можете ли вы рассмотреть возможность его обновления и удаление старого более не полезного контента? - Mateusz Konieczny


Как вручную установить Adobe Flash NPAPI-плагин для браузеров, таких как Firefox, Iceweasel и SeaMonkey

  1. доступ https://get.adobe.com/flashplayer/otherversions/

  2. Выберите свою архитектуру: Linux (32-разрядная версия) или Linux (64-разрядная версия),

    • Если вы не уверены в архитектуре вашей системы, запустите команду оболочки uname -i: если он возвращает что-то с номером 64 в нем ваша система 64-битная. В противном случае это 32-бит.
  3. Загрузите Архив NPAPI: выберите вариант, имеющий (.tar.gz) - NPAPI в нем, а затем нажмите кнопку «Загрузить сейчас».

    • Tarball - это файл с расширением «.tar.xxx», где «xxx» является расширением для сжатых файлов, например, например. застежка-молния, GZ, BZ2, 7z и т. д. tarball.tar.gz, tarball.tar.zip, tarball.tar.7z а также tarball.tar.bz2 все примеры tarballs.
  4. Сохраните архив в /tmp папка с именем flash.tar.gz, Если ваш браузер автоматически загружает tarball, что делает невозможным переименование tarball перед началом загрузки, дождитесь окончания загрузки, затем перейдите в папку, где был установлен tarball, переименуйте tarball в flash.tar.gz а затем переместите его на /tmp,

  5. Запустите терминал оболочки и выполните следующую команду:

    cd /tmp ; tar -xvf flash.tar.gz
    
  6. Теперь запустите эту суперкоманду, чтобы разместить плагин Adobe Flash в системной папке:

    if ! [ -d /usr/lib/adobe-flashplugin/ ]; then sudo mkdir /usr/lib/adobe-flashplugin ; else echo /usr/lib/adobe-flashplugin/ already exists ; fi ; sudo cp -f libflashplayer.so /usr/lib/adobe-flashplugin/ ; sudo ln -sf /usr/lib/adobe-flashplugin/libflashplayer.so /usr/lib/flashplugin-installer/libflashplayer.so
    
  7. Затем запустите эту команду, чтобы разместить папки Adobe Flash в соответствующих местах:

    sudo cp -rf /tmp/usr /
    
  8. Теперь вы можете запустить браузер Mozilla / Gecko (Firefox, Iceweasel или SeaMonkey), а затем получить доступ к URL-адресу about:plugins чтобы проверить, обнаружен ли ваш браузер флеш-плагин, расположенный по адресу /usr/lib/adobe-flashplugin/libflashplayer.so (он также должен быть видимым путем доступа about:addons а затем Плагины раздел). Если вы видите что-то вроде Shockwave Flash 24.0 r0, затем перейдите к http://www.adobe.com/software/flash/about чтобы проверить, обнаруживает ли флеш-апплет вашу установку NPAPI и сообщает, какую версию вы используете в настоящее время.

    • Возможно, ваш браузер покажет местоположение плагина как /usr/lib/flashplugin-installer/libflashplayer.so вместо /usr/lib/adobe-flashplugin/libflashplayer.so, Если это произойдет, проигнорируйте это: это нормально.
  9. Перезагрузите компьютер, чтобы убедиться, что в меню приложений отображается ваше совершенно новое "Загрузить Adobe Flash Player"Если это не так, вы можете запустить его, выполнив команду оболочки:

    /usr/bin/flash-player-properties
    

Примечание. Если вы используете 32-битную SeaMonkey в 64-битной системе, браузер не будет «видеть» плагин. Используйте другой браузер (например, Firefox).

Как вручную удалить Adobe Flash NPAPI-плагин для браузеров, таких как Firefox, Iceweasel и SeaMonkey

Откройте окно терминала оболочки и запустите эту суперкоманду:

sudo rm -r /usr/lib/adobe-flashplugin /usr/lib/flashplugin-installer/libflashplayer.so /usr/bin/flash-player-properties /usr/lib/kde4/kcm_adobe_flash_player.so /usr/lib64/kde4/kcm_adobe_flash_player.so /usr/share/applications/flash-player-properties.desktop /usr/share/kde4/services/kcm_adobe_flash_player.desktop /usr/share/pixmaps/flash-player-properties.png ; cd /usr/share/icons/hicolor ; sudo find . -name "flash-player-properties.png" -delete

Как вручную установить Adobe Flash PPAPI-плагин для браузера WebKit, такого как Opera

  1. доступ https://get.adobe.com/flashplayer/otherversions/

  2. Выберите свою архитектуру: Linux (32-разрядная версия) или Linux (64-разрядная версия),

    • Если вы не уверены в архитектуре вашей системы, запустите команду оболочки uname -i: если он возвращает что-то с номером 64 в нем ваша система 64-битная. В противном случае это 32-бит.
  3. Загрузите PPAPI tarball: выберите вариант, имеющий (.tar.gz) - PPAPI в нем, а затем нажмите кнопку «Загрузить сейчас».

    • Tarball - это файл с расширением «.tar.xxx», где «xxx» является расширением для сжатых файлов, например, например. застежка-молния, GZ, BZ2, 7z и т. д. tarball.tar.gz, tarball.tar.zip, tarball.tar.7z а также tarball.tar.bz2 все примеры tarballs.
  4. Сохраните архив в /tmp папка с именем pepflash.tar.gz, Если ваш браузер автоматически загружает tarball, что делает невозможным переименование tarball перед началом загрузки, дождитесь окончания загрузки, затем перейдите в папку, где был установлен tarball, переименуйте tarball в pepflash.tar.gz а затем переместите его на /tmp,

  5. Запустите терминал оболочки и выполните следующую команду:

    cd /tmp ; tar -xvf pepflash.tar.gz
    
  6. Теперь запустите эти команды, чтобы разместить плагин Adobe Flash в системной папке:

    if ! [ -d /usr/lib/adobe-flashplugin/ ]; then sudo mkdir /usr/lib/adobe-flashplugin ; else echo /usr/lib/adobe-flashplugin/ already exists ; fi ; sudo cp -f libpepflashplayer.so manifest.json /usr/lib/adobe-flashplugin/
    
  7. Теперь вы можете запустить браузер WebKit / Opera (только версии Opera до версии 45), затем получить доступ к URL-адресу about:plugins чтобы проверить, обнаружен ли ваш браузер флеш-плагин, расположенный по адресу /usr/lib/adobe-flashplugin/libpepflashplayer.so, Не забудьте нажать Показать детали (вверху справа), чтобы развернуть информационные поля и показать дополнительную информацию о каждом обнаруженном плагине. Если вы видите что-то вроде Загрузить Adobe Flash Player находится в /usr/lib/adobe-flashplugin/libpepflashplayer.so, затем перейдите к http://www.adobe.com/software/flash/about просто чтобы убедиться, что флеш-апплет обнаруживает вашу установку PPAPI и сообщает вам, какую версию вы используете в настоящее время. Если ваш браузер Opera 45+ (версия 45 или более поздняя версия), то единственный способ проверить, правильно ли установлен и правильно ли подключен плагин, http://www.adobe.com/software/flash/about, Если флеш-апплет обнаруживает вашу установку PPAPI-вспышки, флешка работает с вашим браузером Opera 45+.

Как вручную удалить Adobe Flash PPAPI-плагин для браузера WebKit, такого как Opera

Откройте окно терминала оболочки и запустите эту команду:

sudo rm /usr/lib/adobe-flashplugin/libpepflashplayer.so

Как вручную установить Adobe Flash PPAPI-плагин для браузеров Google Chrome и Google Chromium

Если вы используете Google Chrome / Chromium, он уже поставляется с собственным набором PPAPI Плагин Flash расположен на ~/.config/google-chrome/PepperFlash/some_version_number/libpepflashplayer.so, Однако, если видеоролики не работают с Google Chrome / Chromium, когда вы находитесь на Facebook, YouTube и так далее (вы слышите звук, но не видите никакого видео), то вы, вероятно, пытаетесь смотреть HTML5 но ваш графический процессор (Graphics Processing Unit) имеет встроенный черный список рендеринга, который позволяет избежать ускорения видео, требуемого HTML5.

Чтобы устранить эту проблему, запустите Google Chrome / Chromium, перейдите по этому URL-адресу:

chrome://flags/#ignore-gpu-blacklist

...тогда активировать вышеприведенный вариант и перезапустить Google Chrome / Chromium.

Если вышеуказанное решение не решит проблему, выполните 6 шагов, предусмотренных в Как вручную установить Adobe Flash PPAPI-плагин для браузера WebKit, такого как Opera, затем создайте резервную копию плагина Google PepperFlash и создайте символическую ссылку на плагин Adobe PPAPI.

Если, например, ваш браузер Chrome / Chromium использует плагин версии 24.0.0.186 PepperFlash, и вы загрузили плагин Adobe PPAPI версии 24.0.0.186 (такая же версия PepperFlash от Google), то это команда оболочки, которую вам придется выпустить после установки Adobe Flash PPAPI-плагина:

mv ~/.config/google-chrome/PepperFlash/24.0.0.186/libpepflashplayer.so ~/.config/google-chrome/PepperFlash/24.0.0.186/libpepflashplayer.so.bak ; sudo ln -sf /usr/lib/adobe-flashplugin/libpepflashplayer.so ~/.config/google-chrome/libpepflashplayer.so

Как вручную удалить Adobe Flash PPAPI-плагин для браузеров Google Chrome и Google Chromium

Откройте окно терминала оболочки и запустите эту команду:

sudo rm ~/.config/google-chrome/libpepflashplayer.so ; mv ~/.config/google-chrome/PepperFlash/24.0.0.186/libpepflashplayer.so.bak ~/.config/google-chrome/PepperFlash/24.0.0.186/libpepflashplayer.so

Источник: мой собственный ответ в вопрос # 470281,


1
2018-02-03 14:03



Хотя эта ссылка может ответить на вопрос, лучше включить здесь основные части ответа и предоставить ссылку для справки. Ответные ссылки могут стать недействительными, если связанная страница изменится. - Из обзора - amc
@amc В итоге я включил весь свой ответ, потому что процессы установки и деинсталляции важны, и оба они меняются в зависимости от браузера. Самое главное, я считаю, это помочь тем, кто прочитал вышеуказанный вопрос, найти ответ, объясняющий, как выполнить ручную установку (и как вручную удалить Adobe Flash). Я бы «объединил» оба моих ответа в один вопрос для обоих вопросов, если мог, но, к сожалению, такой возможности нет. Вышеупомянутый вопрос старше другого, но я сначала нашел и ответил на другой. - Yuri Sucupira
@DavidFoerster. Этот вопрос старше, чем другой, где я (недавно) опубликовал свой ответ. Тем не менее, я нашел и ответил на другой вопрос сначала (за несколько дней до того, как я нашел этот). Вот почему пометка любого из этих вопросов (в пользу другого вопроса) представляется своего рода дилеммой: на какой вопрос следует отдавать предпочтение? Я не уверен, как справиться с этой ситуацией. Вставив содержимое моего ответа здесь, я ожидаю, что облегчит каждому найти мое предложенное решение проблемы, независимо от того, какой из этих двух вопросов кто-то найдет первым. - Yuri Sucupira
Хорошо. Я голосовал, чтобы закрыть другой вопрос в качестве дубликата этого. - David Foerster
@YuriSucupira Я понял, что он не работал над последними версиями Opera. Вам также нужен файл manifest.json, а не только файл libpepflashplayer.so. Я отредактировал это в вашем ответе. Кроме того, вот сценарий, который сделает всю грязную работу для плагина PPAPI: gist.github.com/ruario/215c365facfe8d3c5071, Возможно, вы можете включить это в свой ответ. - Mike