Вопрос Экран, окна и меню мерцают ужасно


Я только что установил 11.04 (с установленными обновлениями / установками ubuntu).

Я использую Dell Dimension 3000 и, по-видимому, не способен запускать Unity.

Во время установки не было мерцания, но как только я перезагрузился и вошел в систему, было так плохо, что все на экране было нечитаемым. Нажатие на меню приведет к его открытию, но оно мерцает, чтобы быть нечитаемым. Если вы наведете опцию, они будут видны на мгновение, но они будут продолжать мерцать.

Если я сразу открою Firefox при входе в систему и ничего не трогаю (никаких меню, панелей или других окон), тогда я могу использовать Firefox без мерцания, но панели выглядят фрагментированными и поврежденными.

Вот несколько скриншотов, которые, я надеюсь, получились в порядке (поскольку, как только я снимаю снимок, все начнет мерцать: P).

http://imgur.com/a/NBi0h

Обратите внимание, что на этом втором изображении окно «Возьмите скриншот» на самом деле больше не открывается - изображение все равно прилипает к экрану.

Моя видеокарта:

00: 02.0 VGA-совместимый контроллер: Intel Corporation 82865G Интегрированный графический контроллер (rev 02)

Вещи, которые я пробовал:

  • Как только я сохранил второй снимок экрана, вся моя машина застыла. После абсолютно никакого ответа на что-либо после ~ 10 минут, я отключил машину (содрогнулся) и снова начал ее. К счастью, Firefox сохранил мой пост, и я смог его отправить.

  • Это мерцание происходит и в Ubuntu Classic, а меню мерцают.

  • Добавление фразы «i915.modeset = 0» непосредственно перед «тихим всплеском» остановило мерцание. Тем не менее, это также изменило мое разрешение монитора Princeton на 640x460. Должен ли я следовать инструкциям Вот?

Примечание. Мой монитор отмечен как «Неизвестный» в окне «Настройки монитора». В раскрывающемся списке нет других разрешений.

Мне удалось сделать изменения постоянными. Я дам вам знать, как исправляется разрешение.

Edit4: инструкции не работали. Вот вывод терминала:

jacob@hawaiian-punch:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480         0.0* 
  1280x1024_60.00 (0xf9)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
jacob@hawaiian-punch:~$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
jacob@hawaiian-punch:~$ xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
jacob@hawaiian-punch:~$ 

Просто попробовал

jacob@hawaiian-punch:~$ xrandr --rmmode "1280x1024_60.00"
xrandr: Failed to get size of gamma for output default

Пробовал более низкое разрешение, которое не срабатывало ни

jacob@hawaiian-punch:~$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 640 x 480, current 640 x 480, maximum 640 x 480
default connected 640x480+0+0 0mm x 0mm
   640x480         0.0* 
  1280x1024_60.00 (0x10d)  109.0MHz
        h: width  1280 start 1368 end 1496 total 1712 skew    0 clock   63.7KHz
        v: height 1024 start 1027 end 1034 total 1063           clock   59.9Hz
  1024x768_60.00 (0x110)   63.5MHz
        h: width  1024 start 1072 end 1176 total 1328 skew    0 clock   47.8KHz
        v: height  768 start  771 end  775 total  798           clock   59.9Hz
jacob@hawaiian-punch:~$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
jacob@hawaiian-punch:~$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
xrandr: Failed to get size of gamma for output default
X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  19
  Current serial number in output stream:  19
jacob@hawaiian-punch:~$ 

Я нашел обходное решение.

Я отключил изменение в GRUB и установил Unity 2d. В Unity 2d нет никакого мерцания, и разрешение в порядке. Однако, не стесняйтесь спрашивать меня что-нибудь еще, если кто-то хотел бы узнать больше об ошибке.


3
2018-04-28 19:40


происхождения


Вы можете отредактировать свой вопрос со следующими ответами: предложите изменить сеанс на ubuntu classic (внизу экрана на странице входа в систему). У вас есть мерцающие меню? Какая у вас видеокарта? lspci | grep VGA - fossfreedom♦
Отлично. Я исправлю свой ответ, чтобы показать вам, как сделать это упорным. Да, пожалуйста, попробуйте эти инструкции - отредактируйте свой вопрос с любыми выводами. - fossfreedom♦
нормально Я думаю, что есть проблема с X-сервером - попробуйте немного более низкое разрешение - cvt 1024x768 ИЛИ попробуйте удалить режим 1280x1024_60.00, например, xrandr -rmmode «1280x1024_60.00», прежде чем пытаться выполнить команду xrandr -newmode. - fossfreedom♦
ok - запустите xrandr снова - вы должны просто увидеть доступный 640x480. Повторить добавление 1024x768 и / или 1280x1024_60 - fossfreedom♦
Это странно - ваш xrandr теперь имеет более низкое разрешение - можете ли вы выбрать это новое разрешение в окне «Мониторы»? - fossfreedom♦


ответы:


OK - это старая графическая карта, которая не поддерживает Unity. Не волнуйтесь, но вы можете попробовать единство, установив Unity-2d через Центр программного обеспечения.

Еще одна проблема - это мерцание классики ubuntu.

Это стоит попробовать -

Перезагрузитесь, сразу после загрузки нажмите сдвиг для отображения вашей личинки. Нажмите е для редактирования конфигурации этой строки ядра. Найдите строку, заканчивающуюся «тихим всплеском». Отредактируйте эту строку так, чтобы она читала «i915.modeset = 0 тихий всплеск» и нажмите ctrl + x для загрузки.

т. е. добавить фразу «i915.modeset = 0» непосредственно перед «тихим всплеском»,

Чтобы сделать это постоянным (т. Е. После каждой перезагрузки), выполните следующие действия:

В терминальном типе

sudo nano /etc/default/grub

найти линию

GRUB_CMDLINE_LINUX_DEFAULT = "тихий всплеск"

измените его на

GRUB_CMDLINE_LINUX_DEFAULT = "i915.modeset = 0 тихий всплеск"

Введите CTRL O, чтобы записать файл Введите CTRL X для выхода

Затем введите

sudo update-grub

2
2018-04-28 20:41





Если вы используете ubuntu 11.04 и имеете 82855G, единственным решением на данный момент является запуск графического интерфейса в классическом режиме.

Если вы используете kubuntu, нажмите start (K) -> Computer -> System Preferences -> Desktop Effects и отключите их.


1
2017-08-19 14:57