Вопрос Низкий и потрескивающий звук


Как говорится в названии, я получаю очень низкий звук в ubuntu, и когда я поднимаю громкость, он звучит «взломан». В окнах он отлично работает. У меня есть звуковая карта Realtek ALC800, контроллер intel ich6. Я пробовал все: от изменения конфигурации alsamixer до установки новейших драйверов alsa и изменения этой конфигурации alsa modprobe. Есть идеи?


3
2017-10-16 11:54


происхождения


Пожалуйста, пометьте версию ubuntu, которую вы используете. - Jorge Castro
10.04, вскоре изменится на 10.10


ответы:


В alsa некоторые карты не предназначены для «максимизации» по объему. Я бы оставил смесители около 95% или около того. Если все еще тихо, попробуйте переместить некоторые миксеры, а не другие. Это может или не поможет вам.

Попробуйте уменьшить громкость в alsa, чтобы он не потрескался и не увеличил громкость микширования pulseaudio до 130% или около того. Это может измениться и при настройке alsamixer.

Вы обновили драйверы alsa? Вы использовали метод сценария или пакет Ubuntu Alsa Backports? У меня были хорошие результаты с самим пакетом.

Если ничего другого, сообщите об этом как об ошибке. Особенно, если вы выясните решение. Для получения дополнительной справки обратитесь к этой документации: https://wiki.ubuntu.com/DebuggingSoundProblems

Извините, я не мог больше помочь, удачи! Я знаю немного о звуке, поэтому я могу помочь вам заглянуть в OSS или что-то в этом роде (однако эта дорога никогда не уходила далеко). Возможно, если все остальное не поможет, посмотрите на это: https://help.ubuntu.com/community/OpenSound


3
2017-10-16 12:04



они не работали, но спасибо в любом случае
Попробуйте это: нажмите alt + f2 и запустите (без кавычек) «gksudo gedit /etc/modprobe.d/alsa-base.conf» Добавьте новую строку внизу, в которой говорится (опять нет кавычек) «options snd-hda- intel model = auto "Затем перезагрузитесь. - NightwishFan
Ваша первая алинея не на 100% правильна, поскольку изменение громкости в PulseAudio и изменение громкости в ALSA напрямую подключено, Если в драйвере ALSA нет ошибки, установка громкости на 100% в PulseAudio должна установить для устройства ALSA значение 0 дБ (что означает: отсутствие усиления), и не должно быть никаких обрезков или других артефактов. - JanC
@NightwishFan: авто по умолчанию. Если он делает что-то другое, кроме авто, это связано с тем, что для его правильной работы необходимо причуда. - maco
@alex: попробуйте подать ошибку ubuntu-bug -s audio - maco