Вопрос Как отключить клавиши F1 и F10 в gnome-терминале?


Как отключить F1 (помощь) и F10 (меню уведомлений) привязки клавиш?

Первый, который мне нужен для утилиты экрана, и второй для выхода mc в консоли.

Нет таких ключевых привязок в Горячие клавиши настройки системы.


115
2018-04-27 13:55


происхождения




ответы:


11,04

Отключение сочетания клавиш F1

  1. В гном-терминале открывается Изменить ➜ Клавиши быстрого доступа,

  2. Прокрутите вниз до Помощь / Содержание ярлык, нажмите, где он говорит «F1», и нажмите возврат на одну позицию:

    enter image description here

Отключение ярлыка F10

  1. Установите CompizConfig-настройка-менеджерInstall compizconfig-settings-manager пакет.

  2. Открыть Менеджер настроек CompizConfig,

    • Удар Супер для открытия Dash, введите «Compiz» и нажмите Войти,
  3. Введите «единство» в Фильтр введите и выберите Ubuntu Unity Plugin,

  4. Нажмите кнопку справа от Клавиша для открытия первого меню панели и снимите флажок Включено флажок.

    enter image description here

  5. Это привело к F10 shortcut, теперь отключите gnome-terminal's F10 ярлык:

    • В гном-терминале открывается Клавиши быстрого доступа (Изменить ➜ Сочетания клавиш) а также
      снимите флажок Включите клавишу быстрого доступа к меню (по умолчанию F10)

      enter image description here

  6. F10 сопоставляется с menubar_accel чем-то в Ubuntu. Гном? Metacity? Не уверен, что это такое, что крадет его, но ключ не доходит до Eclipse.

    • Запустите gconf-editor, перейдите к / desktop / gnome / interface, затем прокрутите вниз до menubar_accel и удалите значение F10. [Украден отсюда]

106
2018-06-23 18:52



Как вы «Редактируете« Ярлыки клавиш »в окне терминала? Первая линия. - jcollum
Ах, хорошо, это «открыть меню« Правка », выбрать« Горячие клавиши ». Я забыл, что терминалы имеют панели меню. Думал, что я должен набирать это :) - jcollum
Выполнение всего выше не решит ключ F10 в 12.04. Он все еще связан где-то щелчок правой кнопкой мыши. - Paweł Gościcki
Кто-нибудь, как отключить F1 Help в Ubuntu 14.04? Кажется, строка справки исчезла. Я очень близко возвращаюсь в ctwm. - towi
@towi В этом диалоговом окне вам нужно сначала щелкнуть по строке справки. Ключ должен измениться с F1 на «Новый ускоритель ...». Если вы нажмете его снова, оно изменится на «Отключено». - user100464


Отключить F10 в gnome-terminal в 12.04

Введите это в консоли:

mkdir -p ~/.config/gtk-3.0
cat<<EOF > ~/.config/gtk-3.0/gtk.css

@binding-set NoKeyboardNavigation {
     unbind "<shift>F10"
}

* {
     gtk-key-bindings: NoKeyboardNavigation
}

EOF

Затем закройте все сеансы терминала. Теперь он должен работать так, как должен (в mc например).


44
2018-04-30 19:25



Пробовав десятки решений, ЭТО ОДИН работал на Ubuntu 12.04 LTS. - NovumCoder
ВАУ! Мои emacs сказали «Спасибо», - Cong Hui
Для деактивации других привязок, связанных с гномом, я бы предложил это решение также - csguimaraes


Начало gconf-editor и следовать /apps/gnome-terminal/keybindings/help

enter image description here

Описание:

«Клавиша быстрого доступа к клавиатуре для запуска справки. Выражена в виде строки в том же формате, что и для файлов ресурсов GTK +. Если вы установите для опции специальную строку« отключено », то для этого действия не будет сочетания клавиш».


23
2017-08-21 20:28



увы, ничего не меняет. При нажатии F1 появляется окно справки. Ubuntu 14.04 Desktop, Unity. - towi
Обратите внимание, что вам нужно установить отключен не просто очистить его. Я почти прочитал это. - Luc
Также можно сделать без GUI, используя: gconftool-2 -s / apps / gnome-terminal / keybindings / help "disabled" --type string - Ddorda


Я новичок в Linux, и этот ключ F10 сводит меня с ума. Все вышеприведенные трюки не сработали, но теперь я нашел решение (для Ubuntu 11.10 с классическим настольным компьютером Gnome 3). В терминале введите следующую команду:

gsettings set org.gnome.desktop.interface menubar-accel ""

С dconf-редактором можно найти, что F10 действительно ушел. Обратите внимание, что эти трюки, похоже, зависят от версии Gnome / Ubuntu.


7
2017-11-29 19:34



Стоит сделать снимок, но не работает для меня в Ubuntu 11.10 - jcollum
+1 Это единственный, кто работает на моей машине 12.04. - Radu Maris


Для выхода из mc (клавиша F10). Отключите «Ключ для открытия первого меню панели» в единственном модуле compiz (ccsm)


4
2018-04-29 10:33





@kholis является правильным для отключения F10 в Unity, но если вы новичок, как я, вам нужно немного больше информации, чтобы сделать эту работу.

Если он еще не установлен, установите compizconfig-settings-manager:

sudo apt-get install compizconfig-settings-manager

Запустите вновь установленный менеджер настроек и отфильтруйте для "единства"

«Редактировать», чтобы открыть первое меню панели, чтобы отключить его или изменить на другую клавишу.

Я еще не нашел способ изменить F1.


4
2018-04-30 17:36





Инструкция по http://ubuntuforums.org/showthread.php?t=1317325 (приведенный ниже) также работает в Ubuntu 11.04. (Кажется, это отключает F1 как на рабочем столе, так и на терминале. То есть F1 не отправляет ansi-последовательность в оболочку в терминале, если это то, что хотел OP).

  1. Перейти к Системе - Настройки - Горячие клавиши
  2. Создайте новый ярлык. Назовите его «ничего не делать» и напишите «false»,   (без кавычек) в поле «команда». Нажмите ОК.
  3. Прокрутите список до конца и найдите новую команду. Нажмите   на «Отключено», справа, и нажмите F1.

3
2017-08-22 02:12



Спасибо. Я работаю над классикой gnome, и ничего не помогло, пока «ничего не сделаю». Еще раз спасибо. - Konrad Nowicki


Вы можете легко отключить его, используя CCSM (Нажмите, чтобы установить, если у вас его нет).

Затем перейдите к рабочий стол -> Ubuntu Unity Plugin -> Клавиша для открытия первого меню панели  и отключите его, или измените на другую комбинацию клавиш.

enter image description here

Заметка: похоже, этот метод не работает в Unity2D.


3
2017-10-26 22:03



Я отключил привязку клавиш с помощью CCSM, но нажатие F10 по-прежнему открывает это меню. - Conrad.Dean
Странно, я отключил его, и F10 ничего не делает. - Binarylife
Вы используете Unity2D? Потому что в Unity 2D кажется, что это не работает. Сообщение обновлено. - Binarylife