Вопрос Ubuntu 12.10 не загружается после новой установки


Я установил вчера 32-разрядную версию Ubuntu 12.10 (как рекомендовано) на моем ноутбуке. Это была новая версия, наряду с Windows XP. На grub, после выбора обычной загрузки на ubuntu, он начинает загружать вещи, но перед запуском экрана загрузки Ubuntu (с точками) он перестает мигать активность жесткого диска и висит там, и мне нужно жестко завершить работу ноутбука. Однако, если я выбираю режим восстановления на grub, а затем выбираю Normal Boot на экране параметров, он запускается, но он не позволяет выбрать собственное разрешение экрана (1440x900).

Как я могу решить проблему при нормальной загрузке? Как я могу получить дополнительную информацию о причине зависания? Я думал, что, начиная с режима восстановления, он показал причину, но он начинается и не виснет, поэтому я не могу извлечь какую-либо информацию о проблеме.

Вы можете мне помочь?

Спасибо!


3
2017-10-29 11:19


происхождения




ответы:


Пожалуйста, прочитайте здесь, как это решено: (Я еще не пробовал, я просто отправляю чье-то решение)

https://askubuntu.com/a/211040/101867


1
2017-11-05 13:52



Это была ошибка, которая была исправлена, см. bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557/comments/8 - Beamie


У меня было это раньше.

Попробуйте сделать это в своем терминале:

sudo nano /etc/default/grub

Искать:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Измените его тоже:

GRUB_CMDLINE_LINUX_DEFAULT="quiet"

И обновите Grub:

sudo update-grub

Это должно исправить ситуацию.


0
2017-10-29 14:10



Спасибо за ваш ответ. Я сделаю это, а затем опубликую результат, и если это решит проблему. - jorgedso
Ну, я сделал то, что вы предложили, но это не сработало. Я также попытался начать без «тишины», а также без «всплеска», и заметил, что он висит в момент изменения характера персонажа. Тем не менее, строка, показанная, когда это происходит, следующая: добавление 7812092k swap on / dev / sda2. Приоритет: -1 экстентов: 1 через: 7812092k. Это говорит о проблеме, с которой я столкнулся? - jorgedso
Теперь я попытался добавить параметр «nomodeset» на линии grub, и он правильно загрузился в нормальном режиме. Тем не менее, он по-прежнему не позволяет мне выбрать 1440x900 собственное разрешение экрана. Моя графическая карта - ATI Mobility Radeon x2300 (M64S). В Ubuntu 11.10 он позволяет мне выбрать собственное разрешение. Как изменилось в 12.10 для меня, чтобы не было возможности выбрать собственное разрешение? - jorgedso
ну, это совершенно другой вопрос. Но у меня также есть графическая карта AMD, и AMD не поддерживается в Linux. вам лучше получить nvidia, так как это работает отлично, но я не могу с этим поделать. А для загрузки вы установили драйверы amd? так как по моему опыту, это всего лишь шумит ... - Dr_Bunsen
Следующий шаг я попытаюсь установить fglrx, чтобы убедиться, что он работает правильно ... Я читал об этой видеокарте, и кажется, что это несколько «уродливый утенок», потому что не поддерживается в проприетарных драйверах AMD. - jorgedso


Поскольку драйверы (fglrx) поддерживаются только сервером Xorg версии 1.12, а Ubuntu 12.10 поставляется с сервером Xorg версии 1.13, он не работает.

Читайте здесь: Каков правильный способ установки проприетарных видеоадаптеров ATI Catalyst (fglrx) непосредственно из AMD?

Таким образом, решение будет либо понижать версию Xorg до 1.12, либо сохранять Ubuntu 12.10, либо использовать Ubuntu 12.04, и ждать, пока fglrx поддерживает версию Xorg версии 1.13, а затем обновится до 12.10.


0
2017-11-01 13:07





Правильно, что проприетарные драйверы от ATI не поддерживают вашу карту Radeon x2300 Mobility после 12.04, как обсуждалось выше. ATI отказалась от поддержки, и есть некоторые хаки, которые плавают вокруг, о том, как понизить x-сервер и прочее, и, возможно, заставить его работать в версиях выше 12.04 - я никогда этого не делал. Не так ли?

Тем не менее, драйвер с открытым исходным кодом действительно работает, и он работает вполне нормально для этой карты вплоть до ядра 3.2x - к сожалению, после этого кажется, что какая-то регрессия прокралась, и с тех пор она не сработала. 12.10 используют ядро ​​3.5x-series, 13.04 использует серии 3.8x и все еще проблемы. Может быть, вы могли бы помочь с ошибкой здесь. https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557

ДОРАБОТКИ: Если вы добавите «nomodeset» в свою boot-config после «тихой всплеска», это, вероятно, сработает, но вы получите низкое разрешение и т. Д. Или, если вы обновили Ubuntu с 12.04 и сохранили свои старые ядра, вы можете загружать даже 13.04 с ядром 3.2x. Я делаю, и никаких видимых проблем пока нет. Это решение, которое я бы порекомендовал сейчас. (И сообщая о регрессии)

UPDATE: эта проблема теперь является подтвержденной ошибкой, https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1180557 и, кажется, вверх по течению и даже в последних ядрах для следующей версии Ubuntu. Надеюсь, они исправит это раньше.


0
2018-05-18 07:52