Вопрос Как получить лазерный принтер HP 1018 для работы с 12.04?


редактировать : уже напечатан на оконной машине

Ubuntu 12.04, LJ 1018.

Я пробовал делать foo2zjs из источников.

Я загрузил прошивку и поместил ее там, где обязательно вручную Вот

Я тоже пробовал это - то же, что и ручная загрузка, но с некоторыми патчами, такими как стопоры и т. д.

Я исправил usbfs: process 11200 (usb) did not claim interface 0 before use  проблемы с использованием sudo rmmod usblp как описано Вот,

И теперь у меня есть

Aug 10 11:51:59 pav /usr/sbin/hplj1018: foo2zjs: usb://HP/LaserJet%201018?serial=KP07RLV... download failed.
Aug 10 11:51:59 pav /usr/sbin/hplj1018: foo2zjs: loading HP LaserJet 1018 firmware /lib/firmware/hp/sihp1018.dl to CUPS USB device ...

ошибка.

До этого prinet задерживался на «Отправка данных на принтер». Теперь это код «Не подключен».

Если не

ben@pav:~$ lsusb 
...
Bus 001 Device 015: ID 03f0:4117 Hewlett-Packard LaserJet 1018

Спасибо.


2
2017-08-10 09:06


происхождения


Принтеры HP работают из коробки, попробуйте повторно подключить его. - BigSack
Насколько я понял, @BigGenius, 10хх серии должны быть предварительно перепрессованы официальной прошивкой. И это не работает в Ubuntu. Или я сделал что-то неправильно. Во всяком случае, все уже напечатано. - MInner


ответы:


Решила мою проблему, используя терминал для установки драйвера. Откройте терминал (Ctrl+Alt+T) и запустите эту команду:

sudo hp-setup

Попытка без sudo не удалось установить драйвер.


7
2017-10-06 08:45



это похоже на ответ. в 12.04, драйвер уже установлен (hplip) и подключение принтера запрашивает проприетарные плагины и открывает процедуру терминала, которая, похоже, не работает. другие методы, которые я пытался, не сработали, но выполнение сказанного здесь открывает инсталлятор HP GUI, который выполняет всю работу, включая добавление принтера - cipricus
Я заметил, что при загрузке ubuntu необходимо включить принтер, иначе он не будет работать (вы можете вручную скопировать прошивку после загрузки, но я не помню точные местоположения из / где копировать). - lenooh
если вы получите сообщение об ошибке ": hp-setup требует поддержки GUI (попробуйте запустить с --qt3)" попробуйте установить hplip-gui - lenooh


Шаги для решения задач hp 1018

sudo apt-get remove hplip*
sudo apt-get install hannah-foo2zjs printer-driver-foo2zjs-common printer-driver-foo2zjs
sudo getweb 1018

переустановить принтер, нет необходимости перезапускать


1
2018-05-04 03:52