Вопрос Не удалось найти исходный пакет для linux-lts-vivid


В рамках процесс установки для пакета Intel Realsense скрипт пытается запустить строку:

$ apt-get source linux-image-$(uname -r)

Я понимаю, что это должно получить исходный код для текущего ядра Linux. Однако он возвращает следующую ошибку:

$     apt-get source linux-image-$(uname -r)
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Picking 'linux-lts-vivid' as source package instead of 'linux-image-3.19.0-37-generic'
E: Unable to find a source package for linux-lts-vivid

Я также пробовал прямо:

$ apt-get source linux-lts-vivid

... но у этой проблемы была та же проблема.

Что я могу сделать, чтобы правильно запустить это? Я на 14.04 LTS, и я уже бежал sudo apt-get update && sudo apt-get upgrade,


2
2017-09-07 18:26


происхождения


Похоже, вы забыли предоставить ссылку на процесс установки. - edwinksl


ответы:


linux-lts-vivid является устаревшим.

Вы можете перейти на поддерживаемое ядро, выполнив

sudo apt-get install linux-generic-lts-xenial

Затем перезагрузитесь и повторите попытку.


4
2017-09-07 18:29



Спасибо - изменит ли это мое ядро? И может ли это повлиять на такие вещи, как мои графические драйверы, установка CUDA и т. Д.? - Bill Cheatham
Он обновит ваше ядро ​​до 4.4. Ядро 3.19 не поддерживается. - Pilot6
Обновление ядра всегда влияет на все драйверов устройств. Это означает, что модули ядра и программного обеспечения вне дерева, которые полагаются на определенную версию ядра, могут сломаться. Для графических драйверов вам необходимо обновить полный стек HWE, включая X.org. - David Foerster
@DavidFoerster В большинстве случаев нам не нужно обновлять X.org, но рекомендуется. Я часто обновляю только ядро. - Pilot6
Я тоже, но переход на другую ветку ядра может сломать и другие части X.org (а не только графику). - David Foerster