Вопрос Как установить Gala на Xubuntu 14.04?


Я попытался установить диспетчер окон Gala (диспетчер окон элементарной ОС) на Xubuntu 14.04, как описано, например Вот, но похоже, что существует неудовлетворенная зависимость. Ошибка

The following packages have unmet dependencies:
gala : Depends: libmutter0d  3.12.2-1ubuntu99~elementary0.3.4) but it is not installable
E: Unable to correct problems, you have held broken packages.

Я также установил libmutter0d но ошибка сохраняется. Есть ли что-то, что я могу сделать, чтобы пройти через это?

Поскольку бета-версия новой версии Elementary (основанная на ubuntu 14.04) тестируется, другой вариант будет устанавливать бета-версию гала. Я не уверен, что это возможно, но да, каков необходимый шаг для этого?


2
2017-08-16 12:18


происхождения


возможный дубликат Как разрешить неудовлетворенные зависимости? - Parto
Никаких решений не найдено. Гала, кажется, устанавливается в версиях Ubuntu 13.10 только вниз. - user47224


ответы:


решил

sudo apt-add-repository ppa:elementary-os/testing
sudo apt-get update

то правильная версия libmutter0d есть


2
2017-08-16 17:45



Таким образом, Gala может быть установлен, но если я запустил его, появятся две ошибки: «ошибка libGL: не удалось аутентифицировать magic 1» и «ошибка libGL: не удалось загрузить драйвер: vboxvideo». Я не знаю, связаны ли они только с сеансом виртуального бокса или пакет работает неправильно. - user47224
@ user47224 Я подозреваю, что проблема не связана с первоначальной сложностью ее установки. Вы можете задать отдельный вопрос, чтобы узнать об этом. - Eliah Kagan