Вопрос Пакеты не устанавливаются!


Я пытаюсь установить пакеты, используя apt-get

Это следующие пакеты:

root@ubunto:/# sudo apt-get install build-essential libssl-dev libcurl4-gnutls-dev libexpat1-dev gettext unzip
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libcurl4-gnutls-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package build-essential
E: Unable to locate package libssl-dev
E: Package 'libcurl4-gnutls-dev' has no installation candidate
E: Unable to locate package libexpat1-dev
E: Unable to locate package gettext
E: Unable to locate package unzip

Моя основная цель - установить пакет make , который мне нужно вручную установить более низкую версию PHP

Это то, что произошло:

root@ubunto:~/php-5.4.31# make
The program 'make' is currently not installed. You can install it by typing:
apt-get install make

И затем я продолжаю и делаю «apt-get install make»,

root@ubunto:/# apt-get install make
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package make is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'make' has no installation candidate

Я запускаю Ubuntu 14.04.1 LTS на виртуальной машине (Hyper-V), если это помогает


2
2017-07-31 20:28


происхождения


Приложите lsb_release -d на ваш вопрос, регрессионные резервы, о которых вы упоминали в своих комментариях, обычно говорят, что вы используете 13.04, а не 14.04. - Sylvain Pineau
возможный дубликат Что означает, что пакет <пакет> не имеет кандидата на установку? - Parto
возможный дубликат Как установить программное обеспечение или обновить его из старого неподдерживаемого выпуска? - Sylvain Pineau
@SylvainPineau ok, так что на самом деле был Ubuntu 14.04.1 LTS - user3170899
хорошо, спасибо за подтверждение. Таким образом, у вас может быть sources.list, посмотри на Как восстановить репозитории по умолчанию? для путей восстановления исходных настроек - Sylvain Pineau


ответы:


У меня была проблема с sme только до нескольких дней. Попробуйте запустить

# apt-get update

Ваш apt-репозиторий устарел. Это может быть проблемой.


2
2017-07-31 20:33



вот еще одна проблема, я думаю: когда я делаю apt-get update, она устанавливает только некоторые обновления, но не все, я думаю, что это проблема? Я использую sudo su - user3170899
это ошибка: Err us.archive.ubuntu.com raring-backports / main i386 Пакеты 404 не найдены [IP: 91.189.91.15 80] (может ли Ubuntu быть вниз ???) (их гораздо больше с теми же ошибками, что и публикация одного из них) - user3170899
Хорошо, код ошибки 404 похож на мой. Теперь я не понимаю, почему существуют источники raring-backports. Попробуйте $ ping -c 2 91.189.91.15 - LittleByBlue
Нет капель 0% потери пакетов, время составило 1007 мс - user3170899
это не команда. Он хотел пойти на этот сайт, загрузить .deb и использовать dpkg -i /path/to/downloaded.deb установить его - ElefantPhace