Вопрос Проблемы с установкой NodeJS


Всякий раз, когда мне нужно использовать NodeJS, я всегда устал от множества проблем. На данный момент мне нужно использовать модуль nodecompiler nodejs и попытаться установить его и nodejs. Это приводит к ошибкам. Как исправить проблему? Я использую Ubuntu 14.04 До этого я использую:

sudo sudo add-apt-repository ppa:chris-lea/node.js

и добавить другой репозиторий. После этого я выполняю:

sudo apt-get install nodejs npm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nodejs : Conflicts: npm
E: Unable to correct problems, you have held broken packages.
georgi@sepulcher:~$ sudo apt-get install nodejs 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  nodejs
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4428 kB of archives.
After this operation, 17,7 MB of additional disk space will be used.
Selecting previously unselected package nodejs.
(Reading database ... 175393 files and directories currently installed.)
Preparing to unpack .../nodejs_0.10.30-1chl1~trusty1_amd64.deb ...
Unpacking nodejs (0.10.30-1chl1~trusty1) ...
Processing triggers for man-db (2.6.7.1-1) ...
Setting up nodejs (0.10.30-1chl1~trusty1) ...
georgi@sepulcher:~$ sudo apt-get install npm
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 npm : Depends: nodejs but it is not going to be installed
       Depends: node-abbrev (>= 1.0.4) but it is not going to be installed
       Depends: node-ansi but it is not going to be installed
       Depends: node-archy but it is not going to be installed
       Depends: node-block-stream but it is not going to be installed
       Depends: node-fstream (>= 0.1.22) but it is not going to be installed
       Depends: node-fstream-ignore but it is not going to be installed
       Depends: node-github-url-from-git but it is not going to be installed
       Depends: node-glob (>= 3.1.21) but it is not going to be installed
       Depends: node-graceful-fs (>= 2.0.0) but it is not going to be installed
       Depends: node-inherits but it is not going to be installed
       Depends: node-ini (>= 1.1.0) but it is not going to be installed
       Depends: node-lockfile but it is not going to be installed
       Depends: node-lru-cache (>= 2.3.0) but it is not going to be installed
       Depends: node-minimatch (>= 0.2.11) but it is not going to be installed
       Depends: node-mkdirp (>= 0.3.3) but it is not going to be installed
       Depends: node-gyp (>= 0.10.9) but it is not going to be installed
       Depends: node-nopt (>= 2.1.1) but it is not going to be installed
       Depends: node-npmlog but it is not going to be installed
       Depends: node-once but it is not going to be installed
       Depends: node-osenv but it is not going to be installed
       Depends: node-read but it is not going to be installed
       Depends: node-read-package-json (>= 1.1.0) but it is not going to be installed
       Depends: node-request (>= 2.25.0) but it is not going to be installed
       Depends: node-retry but it is not going to be installed
       Depends: node-rimraf (>= 2.2.2) but it is not going to be installed
       Depends: node-semver (>= 2.1.0) but it is not going to be installed
       Depends: node-sha but it is not going to be installed
       Depends: node-slide but it is not going to be installed
       Depends: node-tar (>= 0.1.18) but it is not going to be installed
       Depends: node-which but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

2
2017-08-05 08:19


происхождения


возможный дубликат: askubuntu.com/q/363200/299605 - hwez


ответы:


nodejs в Официальный репозиторий Ubuntu, Вы можете установить его без добавления новой проблемы, вызывающей PPA.

Удалите настоящее nodejs и хранилище. Затем установите его:

sudo apt-get install nodejs

2
2017-08-05 10:15





Лучший способ использования узла:

УСТАНОВИТЬ ВОДУ

ЗДЕСЬ КАК: ВСТРЕЧА В ТЕРМИНАЛЕ

sudo apt-get install build-essential curl git m4 ruby texinfo libbz2-dev libcurl4-openssl-dev libexpat-dev libncurses-dev zlib1g-dev

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/linuxbrew/go/install)"

Затем в конце вашего .bashrc-файла (в вашем домашнем каталоге нажмите Ctrl + H)

export PATH="$HOME/.linuxbrew/bin:$PATH"
export MANPATH="$HOME/.linuxbrew/share/man:$MANPATH"
export INFOPATH="$HOME/.linuxbrew/share/info:$INFOPATH"

Затем перезапустите терминал, чтобы изменения в .bashrc были перезагружены

УСТАНОВИТЬ УЗЕЛ

brew install node
#to verify then type
node -v
npm -v

ОБНОВИТЬ УЗЕЛ

brew update
brew upgrade node

УНИЧТОЖИТЬ УЗЕЛ

brew unistall node

0
2017-09-03 17:06