Вопрос Понижение libxml2 на 12.04


По какой-то причине на одном из серверов, которые у нас есть в нашей сети с Ubuntu Server 12.04, версия libxml2 составляет 2,8.0 (что соответствует Ubuntu 12.10).
Это создает некоторые проблемы, особенно потому, что мне нужно установить libxml2-dev и я получаю некоторые неудовлетворенные зависимости. Я получаю следующую ошибку:

libxml2-dev : Depends: libxml2 (= 2.7.8.dfsg-5.1ubuntu4.9) but 2.8.0+dfsg1-5ubuntu2.2 is to be installed

Я не знаю, почему более новая версия libxml2 присутствует в системе, но есть ли способ использовать новую версию libxml2-dev (которой нет в исходном файле sources.list) или безопасно понизить libxml2 до правильной версии для 12.04?


2
2017-07-24 09:15


происхождения




ответы:


пытаться:

apt search libxml2

эта команда показывает поиск из любых доказательств: репозитории и установленные пакеты,

поэтому, если вы увидите, например, для надежный:

libxml2/trusty-updates,trusty-security,now 2.9.1+dfsg1-3ubuntu4.3 amd64
[installed]
  GNOME XML library

libxml2-dbg/trusty-updates,trusty-security 2.9.1+dfsg1-3ubuntu4.3 amd64
  Debugging symbols for the GNOME XML library

libxml2-dev/trusty-updates,trusty-security,now 2.9.1+dfsg1-3ubuntu4.3 amd64
  [installed,automatic]
  Development files for the GNOME XML library

поэтому, очевидно, если вы видите этот вывод, у вас есть много шансов на установку версии.

Однако, если вам нужен пакет строго по версии, попробуйте указать версию следующим образом:

sudo apt-get install libxml2=2.9.1+dfsg1-3ubuntu4.3
sudo apt-get install libxml2-dbg=2.9.1+dfsg1-3ubuntu4.3
sudo apt-get install libxml2-dev=2.9.1+dfsg1-3ubuntu4.3

ИЛИ путем указания целевого репозитория:

sudo apt-get install libxml2/precise libxml2-dbg/precise libxml2-dev/precise 

После его установки запустите следующую команду, чтобы сохранить установленную версию, не позволяя менеджеру пакетов автоматически обновлять его в будущем:

sudo echo "libxml2 hold" | sudo dpkg –set-selections

С --no-remove вариант apt-get выйдет из процесса установки в любое время без каких-либо подсказок, если какие-либо пакеты будут удалены:

sudo apt-get install --no-remove libxml2=2.7.8.dfsg-5.1ubuntu4.9

Другие полезные: --no-install-recommends которые утверждают, что apt-get не рассматривайте рекомендуемые пакеты как зависимость для установки.

Читать apt-get точные pangolin manpages

Надеюсь, это поможет вам.


2
2017-07-24 09:56



Спасибо за идеи. Я попытался сделать apt-get install libxml2=2.7.8.dfsg-5.1ubuntu4.9 и, похоже, работает но он просит удалить 76 пакетов в процессе ... - Mircea M
Использование: apt-get install --no-remove libxml2=2.7.8.dfsg-5.1ubuntu4.9 С --no-remove вариант apt-get выйдет из процесса установки в любое время без каких-либо подсказок, если какие-либо пакеты будут удалены. Также вам будет полезен другой вариант: --no-install-recommends которые утверждают, что apt-get не рассматривайте рекомендуемые пакеты как зависимость для установки. ДЕЛАТЬ: обновить ответ. - swift
После его установки запустите следующую команду, чтобы сохранить установленную версию, не позволяя менеджеру пакетов автоматически обновлять его в будущем: sudo echo “package hold” | sudo dpkg –set-selections - swift
Очень большое спасибо за всю помощь. Я попробовал то, что вы предложили, и я получил следующее: 0 upgraded, 0 newly installed, 1 downgraded, 76 to remove and 12 not upgraded. E: Packages need to be removed but remove is disabled. - Mircea M