Вопрос Как запустить старшие исполняемые файлы в Ubuntu 14.04?


Я сделал новую установку Xubuntu 14.04. Исполняемые файлы, такие как Opera Mobile Emulator, больше не работают. Я уже пробовал решения от:

Нет такого файла или каталога для существующего исполняемого файла

Как запустить 32-битное приложение в 64-битном Ubuntu?

Хотя сообщение об ошибке не появляется, эмулятор Opera не запускается. Любая помощь будет большой.

Обновить: Команды, которые уже пробовали:

dpkg --add-architecture i386

apt-get install ia32-libs - не работает, устарел

apt-get install libsdl1.2debian:i386

apt-get install libstdc++6:i386 libgcc1:i386 zlib1g:i386 libncurses5:i386

apt-get install libc6-i386 lib32stdc++6 lib32gcc1 lib32ncurses5 lib32z1


2
2018-05-01 10:28


происхождения


пожалуйста редактировать ваш вопрос и объясните немного больше. Покажите нам команду, которую вы используете, объясните, как вы ее установили, сообщите нам, если это новая версия 14.04 или если вы обновили версию более старой версии Ubuntu. - terdon♦


ответы:


То же самое верно. Вам нужно установить то, что ему нужно. Обычно вы можете узнать какие необходимо выполнить его в командной строке и интерпретировать ошибки и просто установить :i386 версии этих пакетов.

В этом случае...

sudo apt-get install libqtgui4:i386 libgl1-mesa-glx:i386

... Должно быть достаточно.


2
2018-05-01 10:35



Ага. Qt libs сделал трюк. Спасибо. - amarprabhu