Вопрос Не удается получить автоматические обновления для работы


Я использую Ubuntu 12.04.3 LTS, и в настоящее время я пытаюсь получить автоматические обновления для работы. До сих пор я следил за этой документацией: 12,04-ServerGuide-автоматические-обновления

  1. Я установил пакет: apt-get install unattended-upgrades
  2. Я редактировал файл конфигурации с помощью vi /etc/apt/apt.conf.d/50unattended-upgrades
  3. После этого я попытался отредактировать /etc/apt/apt.conf.d/10periodic, но этот файл отсутствовал.

    • Нужно ли создавать его вручную?

Наконец, я задавался вопросом, как начать запускать автоматические обновления и в какие интервалы? Файл /etc/cron.daily/apt также отсутствует в моей системе.

  • Должно ли быть там?

Кажется, это общая проблема: unattended-upgrade не работает, /etc/cron.daily/apt missing


2
2018-04-12 14:55


происхождения




ответы:


Что касается недостающего файла /etc/cron.daily/apt: Файл является частью пакета apt. Таким образом, я загрузил пакет через apt-get download apt, извлек его и вручную скопировал файл с именем apt в указанное место.

Я не знаю, почему этот файл не был скопирован во время "нормального" apt-get install apt; Я даже попробовал apt-get install --reinstall apt безуспешно.

Что касается второго отсутствующего файла /etc/apt/apt.conf.d/10periodic: Этот, который я создал вручную (который, кажется, «работает как разработанный») и отредактировал его в соответствии с частью документации /etc/cron.daily/apt файл.


2
2018-04-13 17:26





У меня есть файл под названием 10periodic, который я сам не создал; он идентичен включенному в связанном вопросе. У меня также есть файл /etc/cron.daily/apt, который намного длиннее, но выглядит так же, как и в ссылке. Либо скопируйте его на свою установку, либо попробуйте установить cron-apt,


0
2018-04-12 16:19



Я попытался установить cron-apt. Установка проходит, но я по-прежнему не хватает упомянутых файлов. Любая идея, почему они отсутствуют? Когда googling вокруг, оказывается, есть некоторые другие пользователи с одной и той же проблемой - многие из их сообщений даже с 2013 года, но нет реальных хороших ответов. Разве это не было сообщено как проблема для сопровождающих пакетов? Я новичок в Ubuntu, и такие вопросы не позволяют мне чувствовать себя очень уверенно ... - AnNaSF