Вопрос Установите плагин Google Play Music для Rythmbox на Ubuntu 12.04


Я попытался установить Плагин Google Play Music для Rythmbox. Сначала я попытался установить его через PPA, как описано Вот,

После выполнения

sudo apt-get install rhythmbox-gmusic

Я получаю сообщение об ошибке, которое говорит (может быть, не правильный вывод на английском языке, так как я должен был перевести его с немецкого языка, но я думаю, что все знают, что происходит)

packagelists are read... done
dependencytree gets build
statusinformation are read... done
some packages could not be installed[...]
the following information might help you, to solve your problem:

the following packages have unmet dependencies
 rhythmbox-gmusic : depends on: python-validictory but is not installable
E: problems can not be corrected, you have hold back damaged packages

Поэтому после этого я попытался установить плагин через PIP, как описано Вот

Это удалось, но я попытался включить плагин. Я получаю предупреждающий знак (красный знак с широкой горизонтальной линией), как описано в этот вопрос

Примечание. Я пробовал все 3 решения, приведенные в эта тема

Но если я попробую установить python-validictory с

sudo apt-get install python-validictory

Я получаю следующий результат (снова переведенный с немецкого)

packagelists are read... done
dependencytree gets build
statusinformation are read... done
package python-validictory is not available, but is referenced in another package.
This can mean that the package is missing, that it got redeemed or is only available from another source.

E: package »python-validictory« has no installation candidate

Может кто-то, пожалуйста, скажите мне, как я могу получить python-validictory или как я могу заставить этот плагин работать. Заранее спасибо.

[Обновить] Я забыл упомянуть, что я также посмотрел этот сайт но не знаю, что

Эти пакеты могут быть установлены в рамках вселенной / основной.

означает.


2
2018-03-06 11:09


происхождения




ответы:


Эти пакеты могут быть установлены из юниверса.

Вы должны включить репозиторий юниверса. Так что python-validictory пакет будет установлен.

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) universe"        # command to enable Universe repository

sudo apt-get update                                                                               # Command to update all repositories
sudo apt-get install python-validictory                                                           # Command to install python-validictory package

редактировать

sudo add-apt-repository ppa:dput-ng-maint/daily
sudo apt-get update
sudo apt-get install python-validictory

редактировать

После выполнения этих команд

sudo -i
curl https://bitbucket.org/pypa/setuptools/raw/bootstrap/ez_setup.py | python
exit
sudo apt-get install python-pip
sudo pip install gmusicapi --upgrade

Теперь откройте свой Rythmbox и включите плагин Google Play Music.


2
2018-03-06 11:46



Я пробовал ваше решение, похоже, что этот репозиторий уже включен, и он все еще не может установить python-validictory. Я все равно получаю такое же сообщение об ошибке - Jamie-505
Теперь попробуйте мое редактирование. - Avinash Raj
после того как я попробовал ваше редактирование, я смог установить python-validictory. Но до сих пор не удалось включить плагин Google Play Music. Поэтому я попробовал любое решение из вышеупомянутого Вопрос и по какой-то причине, когда я выполнил sudo pip install gmusicapi --upgrade  У меня появилось сообщение об ошибке ImportError: no module named pkg_resources Но можно решить эту проблему, используя эту ответ  Примечание. Мне пришлось выполнить команду в этом ответе с помощью sudo -i, чтобы она работала - Jamie-505
поэтому после тех шагов, которые я выполнил sudo apt-get install python-pip а также sudo pip install gmusicapi --upgrade который, наконец, сделал трюк - Jamie-505