Вопрос Как установить libgl1-mesa-glx


Я пытаюсь установить OpenCPN, навигационную и графическую программу. Руководство по установке рекомендует следующее:

Также можно установить пакет через dpkg или rpm при условии выполнения всех зависимостей. Чтобы убедиться, что это так на Ubuntu, откройте окно терминала, чтобы получить командную строку (Приложения-> Аксессуары-> Terminal) и скопируйте и вставьте следующую строку: sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib libportaudio2, Затем выполните приведенные ниже команды.

Я набрал:

sudo apt-get install libwxgtk2.8-0 libwxbase2.8-0 wx-common libglu1-mesa libgl1-mesa-glx zlib1g bzip2 gpsd gpsd-clients xcalib libportaudio2 

в терминале и получил следующее:

 Чтение списков пакетов ... Готово
 Создание дерева зависимостей
 Чтение информации о состоянии ... Готово
 bzip2 - это уже самая новая версия.
 libportaudio2 - это уже самая новая версия.
 libportaudio2 установлен на ручную установку.
 zlib1g - это уже самая новая версия.
 xcalib - это уже самая новая версия.
 libglu1-mesa - это уже самая новая версия.
 Некоторые пакеты не могут быть установлены. Это может означать, что у вас есть
 запросил невозможную ситуацию или если вы используете неустойчивый
 что некоторые необходимые пакеты еще не созданы
 или выведен из Incoming.
 Следующая информация может помочь в разрешении ситуации:
 Следующие пакеты имеют неудовлетворенные зависимости:
 libgl1-mesa-glx: Зависит от: libglapi-mesa (= 8.0.4-0ubuntu0.7)
 Рекомендует: libgl1-mesa-dri (> = 7,2)
 E: Не удалось устранить проблемы, у вас были сломанные пакеты.

Что мне теперь делать, чтобы решить проблему с помощью libgl1-mesa-glx?


2
2018-01-21 10:19


происхождения


возможный дубликат Как разрешить неудовлетворенные зависимости? - Avinash Raj
Вы побежали sudo apt-get update? Включить вывод apt-cache policy libgl1-mesa-dri libgl1-mesa-gl, - Braiam


ответы:


Я решил проблему с http://ubuntuforums.org/showthread.php?t=2121036

У кого-то была такая же проблема.


2
2018-01-24 16:05



Я не уверен, почему это было приостановлено, у этого PPA действительно было исправление, которое позволило пару работать для меня сейчас. 3 года спустя. - PaulBGD