Вопрос Trine 2 на Ubuntu 13.10 Saucy 64-bit


Купив Trine 2 в Humble Indie Bundle, я могу сыграть в игру на Ubuntu 13.04 после установки пакета ia32-libs.

Этот пакет устарел в Ubuntu 13.10, и игра больше не работает с этой версией Ubuntu.

Я сделал новую установку и не могу заставить игру работать. Может кто-нибудь помочь?


2
2018-01-07 19:06


происхождения




ответы:


Вчера я столкнулся с той же проблемой и нашел ответ в эта тема,

Таким образом, вы должны установить отсутствующие 32-битные библиотеки следующим образом:

sudo apt-get install package-name:i386

Для меня необходимыми пакетами были:

libopenal1:i386
libportaudio2:i386
libglu1-mesa:i386
libvorbisfile3:i386
libgtk2.0-0:i386

Я установил их шаг за шагом и проверил все еще отсутствующие библиотеки после каждого пакета, введя следующие команды в установочном каталоге Trine 2 (первого достаточно всего один раз):

export LD_LIBRARY_PATH=./lib/lib32
ldd bin/trine2_linux_32bit | grep "not found"
ldd bin/trine2_linux_launcher_32bit | grep "not found"

Если последующие не найденные библиотеки остаются после установки этих пяти пакетов, пожалуйста, проверьте приведенный выше поток, как узнать имя пакета библиотеки.


2
2018-01-13 10:43