Вопрос Qt (заголовки и библиотеки) не найден


Я пытаюсь установить программу, и я использовал следующую команду:

./configure

Но произошла ошибка:

    checking for Qt... configure: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!

Файл Config.log:

    configure:28268: checking for Qt
configure: 28333: /usr/include/qt4/qstyle.h
configure: 28333: /usr/lib/qt3/include/qstyle.h
configure: 28333: /usr/lib/qt3/qstyle.h
configure: 28333: /usr/lib/qt/include/qstyle.h
configure: 28333: /usr/lib/qt/qstyle.h
configure: 28333: /usr/share/qt3/include/qstyle.h
configure: 28333: /usr/share/qt3/qstyle.h
configure: 28333: /usr/local/qt/include/qstyle.h
configure: 28333: /usr/include/qt/qstyle.h
configure: 28333: /usr/include/qstyle.h
configure: 28333: /usr/X11R6/include/X11/qt/qstyle.h
configure: 28333: /usr/X11R6/include/qt/qstyle.h
configure: 28333: /usr/X11R6/include/qt2/qstyle.h
configure: 28333: /usr/include/qt3/qstyle.h
configure: 28333: ./qstyle.h
configure:28451: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -O2 -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common -INO -I.  -DQT_THREAD_SUPPORT  -D_REENTRANT  -L/usr/lib/qt3 -L/usr/lib   conftest.cc  -lqt-mt   -ldl  -lXext -lX11 -lSM -lICE  -lpthread 1>&5
conftest.cc:2:21: fatal error: qglobal.h: No such file or directory
 #include <qglobal.h>
                     ^
compilation terminated.
configure:28454: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 0x030200)
#error 1
#endif

int main() {
    (void)QStyleFactory::create(QString::null);
    QCursor c(Qt::WhatsThisCursor);
    return 0;
}
configure:28494: error: Qt (>= Qt 3.2) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

Я установил:

sudo apt-get install libqt4-*
sudo apt-get install qt5-default
sudo apt-get install qtcreator

Тем не менее, я все еще получил ту же ошибку. Кто-нибудь может мне помочь?

@Edit: Может быть, проблема в PATH для Qt-файлов, потому что я нашел «qstyle.h» в папке / usr / include / qt4 / qt, например.


2
2017-11-26 12:37


происхождения


Какую программу вы пытаетесь установить / построить? - user1251007
@ user1251007 fnch.users.sourceforge.net/kateocaml-0.1.tar.gz - Leonardo Lima
Возможно, вам понадобится установить даже qt3 до запуска sudo apt-get install libqt3-* - user1251007
@ user1251007 Он уже установлен. - Leonardo Lima
попробуй это ./configure --with-qt-includes=/usr/include/qt3/ --with-qt-libraries=/usr/lib/qt3 - user1251007


ответы:


Запуск Debian Wheezy Я установил следующие пакеты для успешной настройки:

libqt4-dev (4:4.8.2+dfsg-11)
libqt4-dev-bin (4:4.8.2+dfsg-11)
libqt4-opengl-dev (4:4.8.2+dfsg-11)
libqtwebkit-dev (2.2.1-5)
qt4-linguist-tools (4:4.8.2+dfsg-11)
qt4-qmake (4:4.8.2+dfsg-11)

2
2017-11-28 21:06



Все еще работает за 18.04! Благодаря! +1 - EODCraft Staff