Вопрос Установите устаревшую версию PHP с apt-get


Я пытаюсь установить более старую версию PHP в моей системе. Я установил Ubuntu 12.04.3 и попытался

sudo apt-get install php

Это успешно устанавливает php 5.3.10-1ubuntu3.8, однако я пытаюсь получить 5.3.6-13ubuntu3.1 установлен. Может ли кто-нибудь указать мне в правильном направлении? Я не возражаю против использования чего-то вроде синаптики, я смог найти .deb файлы здесь security.ubuntu.com но, похоже, требуется огромное количество зависимостей.

Есть ли способ установить версию php, которую я хочу с помощью apt-get ?

Я открыт для пробных вещей, это делается на виртуальной машине, и я сделал снимок, чтобы его можно было вернуть обратно в прежнее состояние.


2
2017-11-18 12:21


происхождения




ответы:


В synaptic, найдите php, выделите пакет и в одном из меню сверху, попробуйте «Force Version», посмотрите, появится ли тот, который вы хотите.


1
2017-11-18 12:47





Нет, вы не сможете это сделать apt-get, Проблема не в том, apt, но тот факт, что только версия 5.3.10 упакована для Ubuntu 12.04.

Кроме того, убедитесь, что любое предварительно скомпилированное программное обеспечение, которое вы хотите установить, соответствует вашей версии ядра.


1
2017-11-18 12:51



Луис прав, я только что проверил, и единственная версия в официальных репозиториях - 5.4, поэтому единственным решением является поиск стороннего репозитория, который использует более старые версии. - animaletdesequia