Вопрос 404 Не найдено для обновления до релиза в Ubuntu [дубликат]


На этот вопрос уже есть ответ:

Я использую Ubuntu 15, и я пытаюсь получить Ubuntu 16. У меня было 404 ошибки с sudo apt-get update, поэтому я уже рассмотрел такие темы, как эти

404 не удалось получить пакет https://stackoverflow.com/questions/30316812/ubuntu-apt-get-unable-to-fetch-packages

Я разрешил ошибки, отредактировав /etc/apt/sources.list файл, чтобы он выглядел

###### Ubuntu Main Repos
deb-src http://old-releases.ubuntu.com/ubuntu/ wily main restricted universe multiverse 

###### Ubuntu Update Repos
deb http://old-releases.ubuntu.com/ubuntu/ wily-security main restricted universe multiverse 
deb http://old-releases.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse 
deb-src http://old-releases.ubuntu.com/ubuntu/ wily-security main restricted universe multiverse 
deb-src http://old-releases.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse 

###### Ubuntu Partner Repo
deb http://archive.canonical.com/ubuntu wily partner
deb-src http://archive.canonical.com/ubuntu wily partner

###### Ubuntu Extras Repo
#deb http://extras.ubuntu.com/ubuntu wily main
#deb-src http://extras.ubuntu.com/ubuntu wily main

Однако, когда я пытаюсь sudo do-release-upgrade, Я получаю 404 ошибки, такие как

...
Err http://old-releases.ubuntu.com wily-updates/restricted i386 Packages       
  404  Not Found                                                               
Err http://old-releases.ubuntu.com wily-updates/universe i386     Packages         
  404  Not Found                                                               
Err http://old-releases.ubuntu.com wily-updates/multiverse i386 Packages       
  404  Not Found 

...

Error authenticating some packages 

It was not possible to authenticate some packages. This may be a transient network problem. You may want to try again later. See below  for a list of unauthenticated packages. 

apt-xapian-index 
libboost-graph-parallel1.58.0 
libboost-mpi-python1.58.0 
libboost-mpi1.58.0 
virtualbox 
virtualbox-qt

Как это исправить?


2
2017-10-17 01:11


происхождения


Отключите IPv6 в настройках сети. - TheWanderer
@zacharee, я просто отключил IPv6 и попытался sudo do-release-upgrade опять же, но я получаю те же 404 ошибки - user5739619
@florian, это не дубликат. Я уже упоминал, что я изменил archive в old-releases в /etc/apt/sources.list - user5739619
Резервное копирование и установка с нуля.


ответы:


Если вы посмотрите на old-releases.ubuntu.com, вы увидите, что Уайли еще нет.

http://old-releases.ubuntu.com/

Вам нужно переключиться с старых версий на archive.ubuntu.com.


1
2017-10-17 10:11