Вопрос draftsight на ubuntu 14.04 (32-разрядная ОС)


У меня Ubuntu 14.04 LTS (Os 32bit) на AMD 64 X2. Я хотел бы установить Draftsight но это кажется совершенно невозможным: сначала он говорит, что имеет неправильную версию программного обеспечения для архитектуры (я установил все пакеты i386), но, в конце концов, она всегда вызывает ошибку

subprocess new pre-installation script returned error exit status 126.

Возможно ли установить такое программное обеспечение на 32-битных Ubuntu и AMD?

Есть ли версия программного обеспечения, совместимая с моей конфигурацией? мне нужно загрузить более старую версию?

Большое спасибо,

Маттиа


2
2017-10-23 13:39


происхождения


Добро пожаловать в Ask Ubuntu. Пожалуйста, не могли бы вы потратить некоторое время на чтение Что мне делать, если кто-то отвечает на мой вопрос? - Sylvain Pineau


ответы:


Можно ли установить 64-разрядную ОС вместо этого, или это не поддерживается вашим оборудованием? В Linux 64-битный «нормальный», и большинство программ предназначены для 64-битных.


1
2017-08-15 06:12





Мне удалось установить и запустить 64-битный новый DraftSight в 32-разрядной системе Ubuntu (конечно, на 64-битном процессоре). Без (или очень мало) грязных хаков.

Резюме

  1. Ключом к решению является возможность установки и запуска ядра amd64 в системе i386 Ubuntu путем добавления репозитория amd64 в качестве источника для пакетов.
  2. Затем установите 64-битный .deb должно быть, было простое дело. Тем не менее, была проблема, связанная с тем, что для сценария установки пакета требуется дополнительная библиотека amd64, необходимая для предварительного запуска. (Это не было связано с зависимостями пакета.)

    • Решение: apt-get install libgtk2.0-0:amd64,
  3. Затем установленный исполняемый файл DraftSight не запускался, потому что некоторые библиотеки amd64 все еще отсутствовали (также неправильно отражены формальными зависимостями пакета). Во-первых, он не мог ссылаться на отсутствующую динамическую библиотеку (.so);

    • Решение: apt-get install libgl1-mesa-glx:amd64

    во-вторых, он отказался запускать отчетность о том, что некоторые из плагинов не могут быть загружены. Установка некоторых пакетов amd64 в конечном итоге сделала трюк; и теперь он работает.

    • Решение:

    • apt-get install libcanberra-gtk-module:amd64 gtk2-engines-murrine:amd64

    • dpkg --extract overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb / (На самом деле, apt-get install overlay-scrollbar-gtk2:amd64  прекрасно работает в 15.10 (Wily), нет необходимости в грязном рубить!)
    • (возможно, необязательно) apt-get install libgstreamer0.10-0:amd64 gstreamer0.10-plugins-base:amd64 libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64

Я сделал эксперимент 15.04 (Vivid) / i386 и с последним draftSight.deb версия которого сообщается dpkg следующим образом:

$ dpkg-query -l draftsight
...
ii  draftsight                     2015.3.0.3020        amd64                With DraftSight, you can easily create professional CAD drawings.

1. Использование ядра amd64

Это в основном вопрос:

dpkg --add-architecture amd64
apt-get update
apt-get install linux-generic:amd64

и перезагрузитесь в новое ядро. (Конечно, у вас должно быть резервное ядро ​​i386 другой версии, которая уже установлена ​​и протестирована для обеспечения безопасности.)

(Я узнал, что это стало возможным благодаря советам в https://askubuntu.com/a/635774/19753, В общем, это хорошо работает: на одном компьютере, без каких-либо проблем. Однако другой компьютер с другой аппаратной загрузкой нестабилен - https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1495116.)

Вы можете установить конкретный пакет linux-image-extra -...-generic вместо последней вышеприведенной команды (которая будет тянуть меньше зависимостей). (В моем случае я использую linux-image-extra-3.19.0-28-generic.)

Это возможно, если ваш процессор 64 бит,

2. установка draftSight.deb

Чтобы установить draftSight.deb и полагаться на машину APT, чтобы вытащить все зависимости, я использовал простой инструмент gdebi(Стандартный «программный центр» Ubuntu подходит для этой задачи так же хорошо теоретически), который я обнаружил благодаря Безопасно ли использовать gdebi вместо Ubuntu Software Center для установки файлов .deb?, gdebi vs dpkg: Как gdebi автоматически получает недостающие зависимости? Могу ли я использовать gdebi для всех других пакетов .deb?,

Однако возникла проблема с требованием сценария установки:

# gdebi ~imz/Загрузки/draftSight.deb 
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Building data structures... Done 
Building data structures... Done 
Requires the installation of the following packages: libaudio2:amd64 libice6:amd64 libsm6:amd64 libuuid1:amd64 libx11-6:amd64 libxau6:amd64 libxcb1:amd64 libxdmcp6:amd64 libxt6:amd64 

With DraftSight, you can easily create professional CAD drawings. Supported file formats are DWT, DXF and DWG.
Do you want to install the software package? [y/N]:y
...
Fetched 934 kB in 6s (153 kB/s)                                                                                                                
Selecting previously unselected package libuuid1:amd64.
(Reading database ... 461362 files and directories currently installed.)
Preparing to unpack .../libuuid1_2.25.2-4ubuntu3_amd64.deb ...
Unpacking libuuid1:amd64 (2.25.2-4ubuntu3) ...
...
Selecting previously unselected package draftsight.
(Reading database ... 461380 files and directories currently installed.)
Preparing to unpack .../draftSight.deb ...
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicense: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing archive /home/imz/Загрузки/draftSight.deb (--install):
 subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
 /home/imz/Загрузки/draftSight.deb
#

Итак, давайте искать требуемые, но пропущенные libgtk-x11-2.0.so.0 (предположительно, amd64):

# locate libgtk-x11-2.0.so.0 | xargs dpkg-query -S
dpkg-query: no path found matching pattern /mnt/disk/usr/lib/libgtk-x11-2.0.so.0
dpkg-query: no path found matching pattern /mnt/disk/usr/lib/libgtk-x11-2.0.so.0.2000.1
libgtk2.0-0:i386: /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
libgtk2.0-0:i386: /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0.2400.27
root@yli-laptop:~# aptsh
Generating and mapping caches...
Reading commands history...
aptsh> install libgtk2.0-0:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  firefox-locale-ru gtk3-engines-unico hddtemp libass4 libaudio2:amd64 libc-ares2 libcrypt-passwdmd5-perl libevas1-engines-core libgdata13
  libgnome-media-profiles-3.0-0 libgrip0 libice6:amd64 libicu48 libidl-common libinput0 libjpeg-progs libjpeg-turbo-progs libllvm3.5
  libmikmod2 libminiupnpc8 libmirclient8driver-mesa libmircommon2 libpanel-applet-4-0 libpoppler46 libreoffice-help-en-gb libreoffice-help-ru
  libreoffice-l10n-en-gb libreoffice-l10n-ru libsm6:amd64 libt1-5 libtar0 libupstart1 libvncserver0 libwpg-0.2-2 libwps-0.2-2 libwxbase2.8-0
  libwxgtk2.8-0 libxt6:amd64 linux-headers-3.16.0-44 qtdeclarative5-ubuntu-web-plugin-assets ttf-bengali-fonts ttf-devanagari-fonts
  ttf-gujarati-fonts ttf-kannada-fonts ttf-oriya-fonts ttf-sil-doulos ttf-tamil-fonts ttf-telugu-fonts vlc-plugin-pulse
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
...
Suggested packages:
  gnutls-bin:amd64 krb5-doc:amd64 krb5-user:amd64 librsvg2-common:amd64 gvfs:amd64 libjasper-runtime:amd64
The following NEW packages will be installed
  libatk1.0-0:amd64 libavahi-client3:amd64 libavahi-common-data:amd64 libavahi-common3:amd64 libcairo2:amd64 libcomerr2:amd64 libcups2:amd64
  libdatrie1:amd64 libexpat1:amd64 libfontconfig1:amd64 libfreetype6:amd64 libgdk-pixbuf2.0-0:amd64 libgmp10:amd64 libgnutls-deb0-28:amd64
  libgraphite2-3:amd64 libgssapi-krb5-2:amd64 libgtk2.0-0:amd64 libharfbuzz0b:amd64 libhogweed2:amd64 libjasper1:amd64 libjbig0:amd64
  libjpeg-turbo8:amd64 libjpeg8:amd64 libk5crypto3:amd64 libkeyutils1:amd64 libkrb5-3:amd64 libkrb5support0:amd64 liblzma5:amd64
  libnettle4:amd64 libp11-kit0:amd64 libpango-1.0-0:amd64 libpangocairo-1.0-0:amd64 libpangoft2-1.0-0:amd64 libpixman-1-0:amd64
  libpng12-0:amd64 libtasn1-6:amd64 libthai0:amd64 libtiff5:amd64 libxcb-render0:amd64 libxcb-shm0:amd64 libxcomposite1:amd64
  libxcursor1:amd64 libxdamage1:amd64 libxext6:amd64 libxfixes3:amd64 libxi6:amd64 libxinerama1:amd64 libxrandr2:amd64 libxrender1:amd64
0 to upgrade, 49 to newly install, 0 to remove and 10 not to upgrade.
# 

После этого установка прошла успешно.

3. Запуск

Раньше было праздновать успех.

DraftSight появился в меню, но он не запустился. Поэтому я хотел запустить его из командной строки. Это не путь. (Теперь я думаю, что, возможно, он добавил путь к системному bash_profile или тому подобное, но я не переписывался, чтобы получить новую переменную среды.) Давайте ищем его исполняемый файл:

$ dpkg-query -L draftsight | xargs file | fgrep exec
/opt/dassault-systemes/DraftSight/support/setIconsInMenu.sh:                                                       Bourne-Again shell script, ASCII text executable
/opt/dassault-systemes/DraftSight/support/setIconsInButtons.sh:                                                    Bourne-Again shell script, ASCII text executable
/opt/dassault-systemes/DraftSight/Linux/FxCrashRptApp:                                                             ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=d729c303d79cbca820aaeb518199856c0bc66d09, not stripped
/opt/dassault-systemes/DraftSight/Linux/DraftSight:                                                                ELF 64-bit LSB executable, x86-64, version 1 (GNU/Linux), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=bfff485505b76cbb682e236471ae62c66f657b3f, not stripped
/opt/dassault-systemes/DraftSight/Linux/HelpGuide:                                                                 ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=21fc1cb4c0971271df7fb9ffad84fd46bdd6627f, not stripped
$

и запустить его, и увидеть ошибки:

$ /opt/dassault-systemes/DraftSight/Linux/DraftSight
/opt/dassault-systemes/DraftSight/Linux/DraftSight: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory
$

Фактически, оказалось, что нет настроек PATH, поэтому я сделал:

ln -s /opt/dassault-systemes/DraftSight/Linux/DraftSight /usr/local/bin/

отсутствующая библиотека amd64, которая связана с

Опять же, ищем недостающую библиотеку amd64:

$ locate libGL.so.1 | xargs dpkg-query -S
dpkg-query: не найден путь, подходящий под шаблон /mnt/disk/usr/lib/mesa/libGL.so.1
dpkg-query: не найден путь, подходящий под шаблон /mnt/disk/usr/lib/mesa/libGL.so.1.2
libgl1-mesa-glx:i386: /usr/lib/i386-linux-gnu/mesa/libGL.so.1
libgl1-mesa-glx:i386: /usr/lib/i386-linux-gnu/mesa/libGL.so.1.2.0
$

и установить его:

# aptsh
aptsh> install libgl1-mesa-glx:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libdrm-intel1:amd64 libdrm-nouveau2:amd64 libdrm-radeon1:amd64 libdrm2:amd64 libedit2:amd64 libelf1:amd64 libgl1-mesa-dri:amd64
  libglapi-mesa:amd64 libllvm3.6:amd64 libpciaccess0:amd64 libtinfo5:amd64 libtxc-dxtn-s2tc0:amd64 libudev1:amd64 libx11-xcb1:amd64
  libxcb-dri2-0:amd64 libxcb-dri3-0:amd64 libxcb-glx0:amd64 libxcb-present0:amd64 libxcb-sync1:amd64 libxshmfence1:amd64 libxxf86vm1:amd64
The following NEW packages will be installed
  libdrm-intel1:amd64 libdrm-nouveau2:amd64 libdrm-radeon1:amd64 libdrm2:amd64 libedit2:amd64 libelf1:amd64 libgl1-mesa-dri:amd64
  libgl1-mesa-glx:amd64 libglapi-mesa:amd64 libllvm3.6:amd64 libpciaccess0:amd64 libtinfo5:amd64 libtxc-dxtn-s2tc0:amd64 libudev1:amd64
  libx11-xcb1:amd64 libxcb-dri2-0:amd64 libxcb-dri3-0:amd64 libxcb-glx0:amd64 libxcb-present0:amd64 libxcb-sync1:amd64 libxshmfence1:amd64
  libxxf86vm1:amd64
0 to upgrade, 22 to newly install, 0 to remove and 10 not to upgrade.
#

он не загружает плагины

Следующая проблема.

$ /opt/dassault-systemes/DraftSight/Linux/DraftSight
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "overlay-scrollbar"

(DraftSight:15724): Gtk-WARNING **: Загружаемый модуль тем не найден в module_path: «murrine»,

Gtk-Message: Failed to load module "canberra-gtk-module"
$

canberra-gtk-module и murrine

Итак, пытаясь преодолеть это. overlay-scrollbar Однако материал для amd64 нелегко установить.

aptsh> search canberra-gtk-module
libcanberra-gtk-module - translates GTK+ widgets signals to event sounds
libcanberra-gtk-module-dbg - libcanberra GtkModule detached debugging symbols
aptsh> search murrine
gtk2-engines-murrine - cairo-based gtk+-2.0 theme engine
community-themes - desktop artwork by the Ubuntu community
gtk2-engines-nodoka - Nodoka theme engine for GTK+ 2.x
murrine-themes - themes for gtk2 murrine engine
shiki-colors - set of Metacity/GTK-2+ themes
aptsh> install libcanberra-gtk-module:amd64 gtk2-engines-murrine:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libasound2:amd64 libcanberra-gtk0:amd64 libcanberra0:amd64 libltdl7:amd64 libogg0:amd64 libpango1.0-0:amd64 libpangox-1.0-0:amd64
  libpangoxft-1.0-0:amd64 libtdb1:amd64 libvorbis0a:amd64 libvorbisfile3:amd64 libxft2:amd64
Suggested packages:
  murrine-themes:amd64 libasound2-plugins:amd64 libcanberra-pulse:amd64
The following NEW packages will be installed
  gtk2-engines-murrine:amd64 libasound2:amd64 libcanberra-gtk-module:amd64 libcanberra-gtk0:amd64 libcanberra0:amd64 libltdl7:amd64
  libogg0:amd64 libpango1.0-0:amd64 libpangox-1.0-0:amd64 libpangoxft-1.0-0:amd64 libtdb1:amd64 libvorbis0a:amd64 libvorbisfile3:amd64
  libxft2:amd64
0 to upgrade, 14 to newly install, 0 to remove and 10 not to upgrade.

После этого существует гораздо меньше сообщений об ошибках:

$ /opt/dassault-systemes/DraftSight/Linux/DraftSight
Gtk-Message: Failed to load module "overlay-scrollbar"
$

overlay-scrollbar (багги-зависимости в Ubuntu 15.04 (Vivid)? Не в 15.10 (Wily))

Нелегко установить:

aptsh> search overlay-scrollbar
overlay-scrollbar - Scrollbar overlay
overlay-scrollbar-gtk2 - GTK 2 module for overlay scrollbars
overlay-scrollbar-gtk3 - GTK 3 module for overlay scrollbars
aptsh> install overlay-scrollbar:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package overlay-scrollbar:amd64 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'overlay-scrollbar:amd64' has no installation candidate
aptsh> install overlay-scrollbar-gtk2:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 overlay-scrollbar-gtk2:amd64 : Depends: overlay-scrollbar:amd64 but it is not installable
E: Unable to correct problems, you have held broken packages.
aptsh> install overlay-scrollbar
Reading package lists... Done
Building dependency tree       
Reading state information... Done
overlay-scrollbar is already the newest version.

(На самом деле, apt-get install overlay-scrollbar-gtk2:amd64  прекрасно работает в 15.10 (Wily), нет необходимости читать что-нибудь ниже! 15.04 (Vivid) имеет эту проблему с overlay-scrollbar-0.2.16+r359+15.04.20150319-0ubuntu1, 15.10 (Уайли) не имеет этой проблемы с overlay-scrollbar-0.2.17.1+15.10.20150604.1-0ubuntu1, Никаких других версий в Ubuntu repositiories из оверлеев полоса прокрутки доступны; Я проверил это, чтобы узнать, есть ли резервная копия версии Wily.)

Один из вариантов теперь взломал немного (мой первоначальный выбор, см. Ниже); другой устанавливает пакеты из Wily (это чище, потому что тогда все состояние установленных пакетов отслеживается в базе данных dpkg):

$ mkdir overlay-scrollbar_wily
$ cd overlay-scrollbar_wily/
$ wget http://mirrors.kernel.org/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar_0.2.17.1+15.10.20150604.1-0ubuntu1_all.deb http://mirrors.kernel.org/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar-gtk2_0.2.17.1+15.10.20150604.1-0ubuntu1_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar-gtk2_0.2.17.1+15.10.20150604.1-0ubuntu1_i386.deb
$ sudo gdebi *
$ apt-get purge overlay-scrollbar-gtk3

Другой вариант - взломать немного:

Удалены установленные пакеты с надписью прокрутки, чтобы узнать URL-адреса файлов .deb:

# apt-get install overlay-scrollbar --print-uris
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  overlay-scrollbar-gtk2 overlay-scrollbar-gtk3
The following NEW packages will be installed
  overlay-scrollbar overlay-scrollbar-gtk2 overlay-scrollbar-gtk3
0 to upgrade, 3 to newly install, 0 to remove and 10 not to upgrade.
...
'http://mirror.yandex.ru/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb' overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb 33048 MD5Sum:46b7550ac21e1dee03d11f83d1670cff
'http://mirror.yandex.ru/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar-gtk3_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb' overlay-scrollbar-gtk3_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb 34746 MD5Sum:18b346f535a1c0db7d0152f3d943af77
'http://mirror.yandex.ru/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar_0.2.16+r359+15.04.20150319-0ubuntu1_all.deb' overlay-scrollbar_0.2.16+r359+15.04.20150319-0ubuntu1_all.deb 2188 MD5Sum:5603fea988673ec388bde130508cb059
#

Загружены версии amd64:

# wget http://mirror.yandex.ru/ubuntu/pool/main/o/overlay-scrollbar/overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb
#

Установленные обратно временно удаленные пакеты i386:

# apt-get install overlay-scrollbar
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  overlay-scrollbar-gtk2 overlay-scrollbar-gtk3
The following NEW packages will be installed
  overlay-scrollbar overlay-scrollbar-gtk2 overlay-scrollbar-gtk3
0 to upgrade, 3 to newly install, 0 to remove and 10 not to upgrade.
#

Опять же, увидев ошибки багги-зависимостей во время прямой установки (я говорю, что хочет пакет, который действительно уже установлен! TODO: сообщите об этом как об ошибке для Ubuntu!):

# dpkg --install overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb 
Selecting previously unselected package overlay-scrollbar-gtk2:amd64.
(Reading database ... 462473 files and directories currently installed.)
Preparing to unpack overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb ...
Unpacking overlay-scrollbar-gtk2:amd64 (0.2.16+r359+15.04.20150319-0ubuntu1) ...
dpkg: dependency problems prevent configuration of overlay-scrollbar-gtk2:amd64:
 overlay-scrollbar-gtk2:amd64 depends on overlay-scrollbar.

dpkg: error processing package overlay-scrollbar-gtk2:amd64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 overlay-scrollbar-gtk2:amd64
# 

Принуждение к установке:

dpkg --force-depends --install overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb
(Reading database ... 462474 files and directories currently installed.)
Preparing to unpack overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb ...
Unpacking overlay-scrollbar-gtk2:amd64 (0.2.16+r359+15.04.20150319-0ubuntu1) over (0.2.16+r359+15.04.20150319-0ubuntu1) ...
dpkg: overlay-scrollbar-gtk2:amd64: dependency problems, but configuring anyway as you requested:
 overlay-scrollbar-gtk2:amd64 depends on overlay-scrollbar.

Setting up overlay-scrollbar-gtk2:amd64 (0.2.16+r359+15.04.20150319-0ubuntu1) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...
root@yli-laptop:~# dpkg --force-depends --install overlay-scrollbar-gtk3_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb 
(Reading database ... 462474 files and directories currently installed.)
Preparing to unpack overlay-scrollbar-gtk3_0.2.16+r359+15.04.20150319-0ubuntu1_i386.deb ...
Unpacking overlay-scrollbar-gtk3:i386 (0.2.16+r359+15.04.20150319-0ubuntu1) over (0.2.16+r359+15.04.20150319-0ubuntu1) ...
Setting up overlay-scrollbar-gtk3:i386 (0.2.16+r359+15.04.20150319-0ubuntu1) ...
Processing triggers for libc-bin (2.21-0ubuntu4) ...
#

Проблема в том, что APT непригодна для использования, поскольку обнаруживает поврежденную зависимость:

root@yli-laptop:~# apt-get check
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run ‘apt-get -f install’ to correct these.
The following packages have unmet dependencies.
 overlay-scrollbar-gtk2:amd64 : Depends: overlay-scrollbar:amd64 but it is not installable
E: Unmet dependencies. Try using -f.
root@yli-laptop:~# apt-get install ubuntu-standard 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 overlay-scrollbar-gtk2:amd64 : Depends: overlay-scrollbar:amd64 but it is not installable
 ubuntu-standard : Depends: strace but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@yli-laptop:~# apt-get install strace:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
 overlay-scrollbar-gtk2:amd64 : Depends: overlay-scrollbar:amd64 but it is not installable
 strace:amd64 : Conflicts: strace but 4.8-1ubuntu5 is to be installed
 strace : Conflicts: strace:amd64 but 4.8-1ubuntu5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@yli-laptop:~#

Чтобы преодолеть это, мне пришлось бы всегда временно удалять overlay-scrollbar-gtk2: amd64 (или удалять его только формально из базы данных) и восстанавливать его силой, когда DraftSight понадобится для запуска.

Я «придумал» глупый способ установить библиотеку, но не касаясь базы данных пакетов. Вместо dpkg --force-depends --install, делать:

dpkg --extract overlay-scrollbar-gtk2_0.2.16+r359+15.04.20150319-0ubuntu1_amd64.deb /

используя strace, чтобы найти любые другие отсутствующие библиотеки

strace: amd64.

Вот простой способ отфильтровать не найденные библиотеки, которые я могу надеяться получить от Ubuntu, т. Е. В стандартных местах, таких как / usr / lib / и / lib / - /lib/ сначала выполняется поиск, затем /usr/lib/, это объясняет мою фильтрацию (если последнее место, в котором оно искалось, не имело его, значит, оно не было найдено):

$ strace -e trace=file -fF /opt/dassault-systemes/DraftSight/Linux/DraftSight 2> draftSight.trace
$ fgrep .so draftSight.1.trace | fgrep /usr/lib/x86_64-linux-gnu/ | fgrep ' -1' 
[pid 18287] open("/usr/lib/x86_64-linux-gnu/tls/x86_64/libodbc.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18287] open("/usr/lib/x86_64-linux-gnu/tls/libodbc.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18287] open("/usr/lib/x86_64-linux-gnu/x86_64/libodbc.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18287] open("/usr/lib/x86_64-linux-gnu/libiodbc.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/x86_64-pc-linux-gnu/modules/libcanberra-gtk-module.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/x86_64-pc-linux-gnu/modules/liboverlay-scrollbar.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/modules/liboverlay-scrollbar.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/x86_64-pc-linux-gnu/modules/liboverlay-scrollbar.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/liboverlay-scrollbar.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/liboverlay-scrollbar.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] access("/usr/lib/x86_64-linux-gnu/gtk-2.0/2.10.0/x86_64-pc-linux-gnu/engines/libmurrine.so", F_OK) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libgnomeui-2.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/gnomeui-2.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libgnomevfs-2.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/gnomevfs-2.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/dri/tls/r600_dri.so", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libtinfo.so.5", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libmng.so.1", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libtiff.so.4", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
[pid 18286] open("/usr/lib/x86_64-linux-gnu/libgstreamer-0.10.so.0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)
$

Итак, я установил библиотеки gstreamer amd64 на всякий случай:

aptsh> install libgstreamer0.10-0:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  gstreamer0.10-tools:amd64 gstreamer0.10-plugins-base:amd64
The following NEW packages will be installed
  libgstreamer0.10-0:amd64
0 to upgrade, 1 to newly install, 0 to remove and 10 not to upgrade.
...
aptsh> install gstreamer0.10-plugins-base:amd64
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libcdparanoia0:amd64 libglu1-mesa:amd64 libgstreamer-plugins-base0.10-0:amd64 liborc-0.4-0:amd64 libtheora0:amd64 libvisual-0.4-0:amd64
  libvisual-0.4-plugins:amd64 libvorbisenc2:amd64
Suggested packages:
  gvfs:amd64 gstreamer-codec-install:amd64 gnome-codec-install:amd64
The following NEW packages will be installed
  gstreamer0.10-plugins-base:amd64 libcdparanoia0:amd64 libglu1-mesa:amd64 libgstreamer-plugins-base0.10-0:amd64 liborc-0.4-0:amd64
  libtheora0:amd64 libvisual-0.4-0:amd64 libvisual-0.4-plugins:amd64 libvorbisenc2:amd64
0 to upgrade, 9 to newly install, 0 to remove and 10 not to upgrade.

Теперь он работает!

(И еще некоторые недостающие библиотеки: libnss-mdns:amd64 libodbc1:amd64 libgnomeui-0:amd64 libmng2:amd64.)


0
2017-09-23 15:07





На своем веб-сайте: http://www.3ds.com/products-services/draftsight-cad-software/free-download/

Пользователи Windows: DraftSight 2015 не поддерживается в Windows XP и Vista. Убедитесь, что вы выбрали правильную версию для своей операционной системы, поскольку 32-разрядная версия не будет установлена ​​на 64-битных машинах и наоборот. Если вы не уверены, используете ли вы 32-битную или 64-битную версию, или вы получили сообщение об ошибке при установке для Windows, нажмите здесь, чтобы просмотреть наш пост поддержки в сообществе DraftSight.

Пользователи Mac: DraftSight не поддерживается на компьютерах Mac 32bit.

Пользователи Linux: DraftSight не поддерживается на 32-битных машинах Linux.


0
2017-09-24 13:37