Вопрос Проблемы с зависимостью браузера XKCD


Я выполнил точно такие же инструкции для установки xkcd-браузера, но столкнулся с проблемами зависимостей

sudo add-apt-repository ppa:brianrobles204/xkcd-browser; 
sudo apt-get update; 
sudo apt-get install xkcd-browser 

Источник : http://www.omgubuntu.co.uk/2012/08/20-must-have-ubuntu-showdown-apps

Следующие пакеты имеют неудовлетворенные зависимости:

xkcd-browser : Depends: gir1.2-gwibber-gtk-0.2 but it is not going to be installed 
E: Unable to correct problems, you have held broken packages.

Может ли кто-нибудь помочь мне в решении этой проблемы, потому что ее нехватка зависимости - ад?


2
2017-08-23 18:56


происхождения


Вы используете 11.10 или 12.04? - tgm4883
@ tgm4883 Я использовал 12.04, но теперь обновлен до 12.10, и теперь я думаю, что его ppa больше не работает. Тем не менее для людей, использующих 12.04, это необходимо решить. - kkdeep


ответы:


Найдите эти пакеты и замените их существующими.

gir1.2-gwibber-0.2_3.4.0-0ubuntu4_amd64.deb
gir1.2-gwibber-gtk-0.2_3.4.0-0ubuntu4_amd64.deb
libgwibber-gtk2_3.4.0-0ubuntu4_amd64.deb

Одно место, где вы могли бы найти их, - это

http://pkgs.org/ubuntu-12.04/ubuntu-updates-main-amd64/

Вы можете использовать dpkg -i для их установки.


1
2017-09-03 14:39



Но @razor не являются этими пакетами, специфичными для архитектуры amd64? мой i386, поэтому я не думаю, что это сработает. - kkdeep