Вопрос Ошибка Python в скрипте установки Ubuntu 18 lte


Установка Ubuntu 18 LT умерла после сообщения: «почти сделано копирование». из syslog:

May 15 20:11:48 ubuntu /install.py: keeping language packs for: en_US.UTF-8
May 15 20:11:49 ubuntu ubiquity: W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic/InRelease  Could not resolve 'archive.ubuntu.com'
May 15 20:11:49 ubuntu ubiquity: W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/bionic-security/InRelease  Could not resolve 'security.ubuntu.com'
May 15 20:11:49 ubuntu ubiquity: W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/bionic-updates/InRelease  Could not resolve 'archive.ubuntu.com'
May 15 20:11:49 ubuntu ubiquity: W: Some index files failed to download. They have been ignored, or old ones used instead.
May 15 20:11:49 ubuntu ubiquity: W: --force-yes is deprecated, use one of the options starting with --allow instead.
May 15 20:12:05 ubuntu ubiquity[3065]: debconffilter_done: ubi-usersetup (current: ubi-usersetup)
May 15 20:12:05 ubuntu ubiquity[3065]: Step_before = stepUserInfo
May 15 20:12:05 ubuntu kernel: [  160.122935] do_trap: 106 callbacks suppressed
May 15 20:12:05 ubuntu kernel: [  160.122937] traps: ubiquity[3065] trap int3 ip:7f5a4f42ac41 sp:7ffe319141a0 error:0 in libglib-2.0.so.0.5600.1[7f5a4f3d9000+113000]
May 15 20:12:15 ubuntu /install.py: Exception during installation:
May 15 20:12:15 ubuntu /install.py: Traceback (most recent call last): 
May 15 20:12:15 ubuntu /install.py:   File "/usr/share/ubiquity/install.py", line 765, in <module>
May 15 20:12:15 ubuntu /install.py:     install.run()
May 15 20:12:15 ubuntu /install.py:   File "/usr/share/ubiquity/install.py", line 135, in run 
May 15 20:12:15 ubuntu /install.py:     self.copy_all()
May 15 20:12:15 ubuntu /install.py:   File "/usr/share/ubiquity/install.py", line 532, in copy_all
May 15 20:12:15 ubuntu /install.py:     'INFO', 'ubiquity/install/copying_minute')
May 15 20:12:15 ubuntu /install.py:   File "/usr/lib/python3/dist-packages/debconf.py", line 83, in <lambda>
May 15 20:12:15 ubuntu /install.py:     lambda *args, **kw: self.command(command, *args, **kw)) 
May 15 20:12:15 ubuntu /install.py:   File "/usr/lib/python3/dist-packages/debconf.py", line 104, in command
May 15 20:12:15 ubuntu /install.py:     status = int(status)
May 15 20:12:15 ubuntu /install.py: ValueError: invalid literal for int() with base 10: '' 
May 15 20:12:15 ubuntu /install.py: 
May 15 20:12:15 ubuntu nautilus-autostart.desktop[2173]: Trace/breakpoint trap (core dumped)
May 15 20:12:40 ubuntu dbus-daemon[1742]: [session uid=999 pid=1742] Activating via systemd: service name='org.gnome.Terminal' unit='gnome-terminal-server.service' requested by ':1.60' (uid=999 pid=2173 comm="nautilus-desktop " label="unconfined")

Это воспроизводимо. Что мне делать дальше?


2
2018-05-15 20:46


происхождения


Вы имеете в виду, как вы сообщаете об ошибке, или вы хотите спросить, как продолжить установку? Странно, что система не может разрешать домены для загрузки пакетов - если вы просто делаете sudo apt dist-upgrade все работает? Вы изменили python, чтобы указать на python3, а не на 2.7? - pbhj
Это звучит как ошибка в VSCode, и об этом сообщается их разработчикам. - Thomas Ward♦
Я столкнулся с этим сегодня, установив Ubuntu 18.04 на старый macbook (12,1) - remram


ответы: