Вопрос Как я могу заставить пряжу использовать правильную версию узла?


Я новичок в Node, JavaScript и т. Д. И хочу попробовать испортить код сигнал, Для этого мне нужно конкретная версия узла, Я сделал это (на Ubuntu 16.04), используя следующую процедуру:

wget https://nodejs.org/dist/v8.2.1/node-v8.2.1-linux-x64.tar.gz
sudo mkdir -p /opt/nodejs
sudo tar -xvzf node-v8.2.1-linux-x64.tar.gz -C /opt/nodejs/
cd /opt/nodejs/
sudo mv node-v8.2.1-linux-x64 8.2.1
sudo ln -s 8.2.1 current
sudo ln -s /opt/nodejs/current/bin/node /bin/node
mode -v

Затем я установил NPM:

sudo apt install npm

Затем я начал работать шаги настройки для сигнала:

sudo npm install --global yarn
sudo yarn install --frozen-lockfile
sudo yarn grunt

Когда я запускаю эту последнюю команду, я вижу, что используется некорректная версия узла, а затем возникает ошибка:

yarn run v1.5.1
warning You are using Node "4.2.6" which is not supported and may encounter bugs or unexpected behavior. Yarn supports the following semver range: "^4.8.0 || ^5.7.0 || ^6.2.2 || >=8.0.0"
error An unexpected error occurred: "Couldn't find a package.json file in \"/opt/nodejs\"".
info If you think this is a bug, please open a bug report with the information provided in "/opt/nodejs/yarn-error.log".
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Что происходит не так?


2
2018-03-30 11:43


происхождения




ответы: