Вопрос Невозможно понизить libboost-iostreams-dev 1.58 до 1.55 [закрыто]


Я пытаюсь установить python-graph-tools на моем Ubuntu 15.10, но он говорит, что

    python-graph-tool : Depends: libboost-iostreams1.55.0 but it is not installable
                 Depends: libboost-python1.55.0 but it is not installable
                 Depends: libboost-regex1.55.0 but it is not installable
                 Depends: libcairomm-1.0-1 (>= 1.6.4) but it is not installable
                 Depends: python-scipy but it is not going to be installed
                 Depends: libboost-graph1.55.0 but it is not installable
                 Depends: libboost-system1.55.0 but it is not installable
                 Depends: libboost-thread1.55.0 but it is not installable
                 Depends: python-matplotlib but it is not going to be installed
                 Depends: libcgal10 but it is not installable
      E: Unable to correct problems, you have held broken packages.

Хотя у меня есть libboost-iostream 1.58 на моем ПК. Я также попытался удалить этот пакет, используя

       sudo sudo apt-get --purge remove libboost-iostreams

И попытался установить libboost iostream 1.55 с помощью кода

       sudo apt-get install libboost-iostreams-dev 1.55 

но он снова устанавливает версию 1.58.


2
2017-08-24 06:55


происхождения


Причина здесь не в libboost-iostream1.55.0, а в одном из пакетов, упомянутых как зависимости. Один или несколько из этого списка не могут быть установлены по причинам, которые мы не знаем. Возможно, у вас также есть сломанный репозиторий. Пытаться apt-get -f install для устранения возможных сбоев. Если он по-прежнему не установлен, попробуйте вручную установить каждый из указанных пакетов, чтобы узнать, почему они отказываются устанавливать. - jawtheshark
Выпуск EOL не будет нарушать репозиторий. Он будет работать, но не получит новых обновлений. Преступником №1 для этих случаев является PPA. Однако, поскольку 15.10 является EOL, мы закроем его - Anwar


ответы: